Login failed, it appears you are offline (again)

I found the old article saying that this issue has been resolved however I am getting the exact same issue “Login failed, it appears you are offline”. I am writing this issue from the same very computer as I am having the problem with. I have check with our IS department as well as our cyber department, this is not being blocked by AV, nor is it being blocked by our firewall. As a matter of fact when I use fiddler to debug the issue every time I click the sign in button I get an HTTP 200 response back. So any help is much appreciated.

Morning @mricci02,

Share you’re log file from your Profile Folder. You can find that with the information from this post (I don’t know what OS you’re using otherwise I’d tell you where to look): Important File Locations - How To / Tutorials - Komodo IDE & Edit | Forums

Carey, I am having trouble, I can’t upload a text file can only be an image. When I attempt to paste the log file I am getting an error about to many links.

@mricci02, you could copy and paste the text here.

I can’t paste the text here. When I paste the text here I get the following error:
Capture
It would be really nice if I could just respond to an email. This seems silly at this point.

Try wrapping the text in a code block so the markdown parser isn’t trying parse links and @s out of your logs.

Hi @careyh I am receiving this error as well when running Komodo 12.0 on my Windows 10 computer. I have pasted the contents to my pystderr.txt below. Please note that for some of the links I have put a space between the https and the rest of the link so that my post contains less than 2 links. Please let me know if you have any suggestions. Thank you!

[2022-10-03 11:03:42,638] [ERROR] console-logger: platform.activestate. com:443 uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown.

(Error code: sec_error_unknown_issuer)
(0) in :0
Traceback (most recent call last):
File “”, line 0, in

[2022-10-03 11:03:42,638] [ERROR] Platform Auth: Login failed with: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data
Traceback from ERROR in ‘Platform Auth’ logger:
Logger.prototype.error@chrome://komodo/content/sdk/logging.js:411:27
this.login/callback@chrome://komodo/content/sdk/auth.js:184:17
this.request2/req.onreadystatechange@chrome://komodo/content/sdk/ajax.js:134:17
injectOpenHandler/tw.openDialog@chrome://komodo/content/global.js:120:22
openDialogWrap@chrome://komodo/content/komodo.js:631:19
ko.windowManager.openWindow@chrome://komodo/content/library/windowManager.js:113:16
this.loginDialog@chrome://komodo/content/sdk/auth.js:168:1
openLoginDialog@chrome://komodo/content/komodo.js:31:25
authenticateUser/<@chrome://komodo/content/komodo.js:27:67
this.authenticated@chrome://komodo/content/sdk/auth.js:44:13
authenticateUser@chrome://komodo/content/komodo.js:27:5
onloadDelay/</<@chrome://komodo/content/komodo.js:456:13

[2022-10-03 11:03:42,638] [ERROR] Platform Auth: Response:
[2022-10-03 11:03:42,638] [ERROR] Platform Auth: Response:
Traceback from ERROR in ‘Platform Auth’ logger:
Logger.prototype.error@chrome://komodo/content/sdk/logging.js:411:27
this.login/callback@chrome://komodo/content/sdk/auth.js:205:17
this.request2/req.onreadystatechange@chrome://komodo/content/sdk/ajax.js:134:17
injectOpenHandler/tw.openDialog@chrome://komodo/content/global.js:120:22
openDialogWrap@chrome://komodo/content/komodo.js:631:19
ko.windowManager.openWindow@chrome://komodo/content/library/windowManager.js:113:16
this.loginDialog@chrome://komodo/content/sdk/auth.js:168:1
openLoginDialog@chrome://komodo/content/komodo.js:31:25
authenticateUser/<@chrome://komodo/content/komodo.js:27:67
this.authenticated@chrome://komodo/content/sdk/auth.js:44:13
authenticateUser@chrome://komodo/content/komodo.js:27:5
onloadDelay/</<@chrome://komodo/content/komodo.js:456:13

[2022-10-03 11:03:42,654] [WARNING] console-logger: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https ://platform.activestate.com//api/v1/login. This can be fixed by moving the resource to the same domain or enabling CORS. (1) in https ://platform.activestate.com//api/v1/login:0
[2022-10-03 11:03:42,657] [WARNING] console-logger: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://platform.activestate.com//api/v1/login. This can be fixed by moving the resource to the same domain or enabling CORS. (1) in https://platform.activestate.com//api/v1/login:0

You might be hitting this known issue which has a workaround here: [2021-11-24 15:49:45,323] [ERROR] console-logger: community.komodoide.com:443 uses an invalid security certificate - Support - Komodo IDE & Edit | Forums

Thanks for the logs. That was really helpful.

Also following up with our network team to see if something might have changed that could be causing this issue:

I am confused, I don’t see anywhere to download the cert from that article. They do reference an intermediate cert that I suppose you could copy and paste into a file. This is really rather silly, what cert am I missing? Can you post it here for download, with instructions for importing to either Trusted root or intermediate cert stores. All this to try to see if a tool works? Maybe I will look elsewhere.

For the known issue error, is there a way to access the Komodo Edit menu if I can’t log in? I can’t seem to get past the “Login failed, it appears you are offline” screen. Thank you!

Having same trouble.

Morning @mricci02,

All the information you need is contained in the post I linked and the post it references.

@efurey612 yikes. True enough. Other than hacking the code base, no this isn’t possible.

This could be an option. If either of you are interested in the hackaround let me know what OS you’re on and I can write the instructions.

If not, I know VS Code is rocking the IDE world still though it is super frustrating to have to add EVERY FEATURE post install. Sublime Text is really good I hear as well and in fact using Komodo Edits Code intel under the hood though they would have diverged quite a bit by now.

Hi Carey, any hackaround would be much appreciated. I did download VS Code but ran into the same frustration of adding every feature post install. I’ll check out Sublime Text as well.

In the meantime, please see the below details for my OS:
Edition: Windows 11 Enterprise
Version: 21H2
OS Build: 22000.978

I’m not a computer person so please let me know if this information is sufficient or if anything else is needed. Thank you so much :slight_smile:

For Windows you’ll need to have 7zip installed.

Note that this will break any integrations with the ActiveState Platform and the ActiveState State Tool:

  1. Uninstall Komodo then re-install BUT change the install directory to your home folder, something like this C:\Users[yourname]\ActiveState Komodo IDE 12
  2. Open File Explorer and navigate to C:\Users[yourname]\ActiveState Komodo IDE 12\lib\mozilla\chrome
  3. Right click on komodo.jar > 7Zip > Open Archive
  4. Click Extract and extract the folders into the chrome folder
  5. Open the following file in a text editor: content\komodo.js
  6. Comment out line 456 and save.
  7. Rename the original komodo.jar to something else, like orig.komodo.jar
  8. In File Explore, in the chrome folder, ctrl + click on the content, locale and skin folder then right click > 7Zip > Add to archive…
  9. Make sure that zip is selected as the archive format.
  10. Name the file komodo.jar.
  11. Click Ok
  12. You should now have a komodo.jar file and a orig.komodo.jar file in your chrome folder.

You should now be able to start Komodo normally and not hit the login screen.

  • Carey

That worked perfectly!! I am now able to open Komodo 12 and run my scripts successfully. Thank you so much!!

Convoluted process but I’m glad it worked!