[2021-11-24 15:49:45,323] [ERROR] console-logger: community.komodoide.com:443 uses an invalid security certificate

digged out from pystderr.log

I believe this is cause by Komodo being on a very old version of Mozilla, too old to know that the community site does in fact have a good cert. I don’t recall the exact details but it has something to do with how/where Komodo check certs.

The community.komodoide.com server has up to date SSL certs.

  • Carey

Does anyone know how to fix this? I assume one just needs to update the root certificate but I’m not sure where to find the setting. I am unable to open Add-ons or change installed packages due to this error.

Tracking this here: Komodo can’t validate valid SSL certs any more · Issue #3945 · Komodo/KomodoEdit (github.com)

@rolfoz fair point. We use Let’s Encrypt for the Komodo community forums so you could install their root cert. I just did that and it seems to get package manager working again.

  1. Grab the cert key from this page: Fix Let’s Encrypt “R3” Root Certificate Expired or SSL Not Trusted Issue - WP Encryption
  2. Save it as “something.crt”
  3. In Komodo Edit menu > Preferences > Web & Browser > View Certificates
  4. Import the file you created in step 2

No restart seems to be needed. Just make sure you exit out of the packages scope by pressing Esc (Commando will “remember” you were in that scope and open it when you open Commando again) then go back into it.

  • Carey

Hi Carey,

Thank You for the information, I can confirm this fix works for me.

Sorry, I tried but it didn,t work for me.

Need more info. Addons system is working fine for me. Start a new thread. This has been resolved. You’re likely having a different issue so we’ll need all the repro details again:

  1. The exact steps your following
  2. What you expect to happen
  3. What happens instead
  4. Your logs