Komodo and Big Sur (DO NOT UPGRADE)

No luck so far. I’m seeing really inconsistent results. I wasn’t able to get passed the Startup Wizard until I killed the sup process looking up where python3 was in the dependencies screen.

A coworker was able to open Komodo, got passed the Startup wizard without issue, got a dialog asking them to restore their workspace, clicked “no” and Komodo hung after the dialog closed.

Any references to similar issues in Mozilla reach as far back as 16 years ago and nothing recently, not that I could find any way. I’m trying to build Komodo on this new dev machine running Big Sur.

I’m impressed you got as far as you did @ssigwart.

I think I fixed the python3 issue with a reinstall with brew. My debugging was on Edit and was really hacky. I unjarred /Applications/Komodo\ Edit\ 12.app/Contents/Resources/chrome/komodo.jar and was manually tweaking it since I couldn’t compile. For now, I just have it return false so you can’t close an unsaved file, but at least it doesn’t hang.

Morning all,

Unfortunately I don’t have any good news for you at this time. It looks like the latest release of OSX 11 (Big Sur) has made breaking changes in relation to how the version of Mozilla Komodo is using works with the OSX SDK. We’re currently investigating the scope of this problem. At this time we advise that Komodo users remain on OSX 10.x.

  • Carey

Hi Carey,
Thanks for this update. It was not the news that I hoped to hear, but so be it.
Fortunately I can use the Windows version of Komodo Ide on my Mac, using the virtual machine provided by Parallels. But I hope I can go back to the Mac version soon.
Vincent

I am running Komodo Version 12 with Big Sur. It initially did not work. I looked into your archives and installed Version 11. That runs smooth. It asked to install Python3 which I allowed it to do.

Today I discovered that fixed version 12 it works just fine for me.

@careyh, I think I found a workaround that solves this and the Edit issue as well. It’s the same as mentioned in Cannot get past initial startup. Just add the following to ~/Library/Application\ Support/KomodoIDE/12.0/XRE/prefs.js:

user_pref("layers.acceleration.disabled", true);
6 Likes

Thank you Ssigwart!
Your solution helped and I can use Komodo IDE 12 now under Big Sur.

That seems to be working for me!

There are quite a few other issues apparent in Komodo on Big Sur so we’ll remain at “Don’t Upgrade”.

Solution worked for me with Edit 11 and Edit 12 !

Thanks for the fast email response too @zakg !

On my system,
~/Library/ApplicationSupport/KomodoIDE/12.0/XRE/prefs.js
is
~/Library/Application\ Support/KomodoIDE/12.0/XRE/prefs.js

1 Like

Hi all. I do not get to the app loading, I am getting this:

“Komodo Edit 12.app” can’t be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information."

Any workaround to this particular issue?

[EDIT] NVM - resolved.

Hi Troels,
locate the app in the Finder (in the folder Apps), rightclick on it, choose ‘Open’. Then you can start the app and circumvent this check.

1 Like

Thanks, all good now.

This fix worked to get me up and running again, since I already upgraded my Mac.

Hi everybody, thanks for your advices !
Unfortunately I don’t find ~/Library/Application\ Support/KomodoIDE/12.0/XRE/prefs.js on my MacBook Pro !
I do find : ~/Library/Application but not after !!!
Thanks in advance
Jacky

Morning @JacquesYves,

Are you using Finder to find it? If yes, you need to allow display of hidden folders. I believe the keybinding to do so it Cmd + Shift + ..

If you’re using the terminal then use tab completions to find each folder as you descend, if you’re not already. They must be there. ~/Library/Application\ Support/ is a standard folder in OSX and if KomodoIDE folder isn’t there then it means you’ve never started Komodo, which you must have by now if you got to this thread.

  • Carey

Thank You so much Careyh and ssigwart : IT WORKS PERFECTLY :pray::pray::pray::rose::rose::rose:

1 Like

thank you so much!!

Hi!
It doesn’t work, or rather, it only works the first time it is opened and then the file prefs.js returns to the original :slightly_frowning_face:
I use MacBook Air M1 with macOS Big Sur

Morning @fsogus, can you elaborate on how you’re coming to that conclusion? That doesn’t sound possible.