Komodo and Big Sur (DO NOT UPGRADE)

Hi all. I do not get to the app loading, I am getting this:

“Komodo Edit 12.app” can’t be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information."

Any workaround to this particular issue?

[EDIT] NVM - resolved.

Hi Troels,
locate the app in the Finder (in the folder Apps), rightclick on it, choose ‘Open’. Then you can start the app and circumvent this check.

1 Like

Thanks, all good now.

This fix worked to get me up and running again, since I already upgraded my Mac.

Hi everybody, thanks for your advices !
Unfortunately I don’t find ~/Library/Application\ Support/KomodoIDE/12.0/XRE/prefs.js on my MacBook Pro !
I do find : ~/Library/Application but not after !!!
Thanks in advance
Jacky

Morning @JacquesYves,

Are you using Finder to find it? If yes, you need to allow display of hidden folders. I believe the keybinding to do so it Cmd + Shift + ..

If you’re using the terminal then use tab completions to find each folder as you descend, if you’re not already. They must be there. ~/Library/Application\ Support/ is a standard folder in OSX and if KomodoIDE folder isn’t there then it means you’ve never started Komodo, which you must have by now if you got to this thread.

  • Carey

Thank You so much Careyh and ssigwart : IT WORKS PERFECTLY :pray::pray::pray::rose::rose::rose:

1 Like

thank you so much!!

Hi!
It doesn’t work, or rather, it only works the first time it is opened and then the file prefs.js returns to the original :slightly_frowning_face:
I use MacBook Air M1 with macOS Big Sur

Morning @fsogus, can you elaborate on how you’re coming to that conclusion? That doesn’t sound possible.

Morning @careyh, I wrote the code user_pref(“layers.acceleration.disabled”, true); in the file prefs.js and then I opened Komodo… after I had worked using the programme for 5 minutes (e.g. I added a remote server) it froze! So I opened the file again and I saw that the code had disappeared :frowning:

@fsogus, did you make the edit while Komodo was running? That, I believe, will get overwritten. Komodo must not be running when you edit the file.

I don’t know… I not remember. I try again and I will write here. Thanks

Hello Careyh!

Whenever I open application support (by following ~/Library/Application\ Support/) I only see two folders, Komodo Edit and KomodoEdit. I do not see a KomodoIDE folder, but I have been using Komdo Edit version 11 since 2017. Is there a reason I don’t see that folder? For context I have a macbook pro as well and I tried using the latter commands on both of the folders that showed up and it didnt work. Thanks in advance as well.

Morning @jweb,

Did you mean you’ve been using Komodo IDE since 2017? If not, then there is no reason that you should have a KomodoIDE profile folder.

  • Carey

Hi Careyh,

I have the same issue as @jweb using Komodo Edit 11. If I go into the KomodoEdit folder I find the same substructure and ultimately the prefs.js file in /XRE. However, if I run user_pref(“layers.acceleration.disabled”, true); I get the following message: “zsh: number expected.” What am I doing wrong?

Cheers,
Binia

Morning @Binia_De_Cahsan,

You have to edit prefs.js by adding user_pref(“layers.acceleration.disabled”, true); to it. It sounds like you tried to run user_pref(“layers.acceleration.disabled”, true); in your terminal which won’t do anything.

Make sure you edit the file with a different program than Komodo and Komodo can’t be running.

  • Carey

Thanks for the help! I managed to find the file path and once I edited prefs.js, I got Komodo running again.

I recently upgraded to Big Sur and I am having an additional problem. I added the user_pref line to the prefs.js file and I am no longer getting the spinning beach ball cursor. I am getting a secondary window, the background is black with what looks like a text entry box near the top. But if I click on it I don’t get a text cursor. If I click on the close icon the entire application shuts down. If I click on the minimize icon I can access the edit window but none of the controls work. Any ideas what this window is and how to dismiss it without closing the application.

@Ralph_Bailets please start a new thread.