Fix Komodo not Starting On Big Sur

If you’ve upgraded to Big Sur, you likely can’t start Komodo anymore. See the fix here: Komodo and Big Sur (DO NOT UPGRADE):

I am not a programmer, so I don’t understand how to add the “work arounds” in the hidden folder. Help! I am trying to get a book published to Kindle and can’t open the file!!

Hey congrats on the book @2753candace,

Explicit steps to apply the workaround:

  1. For whatever OS you’re on, find your Komodo profile folder
  2. Open the XRE/prefs.js file in some other text editor
  3. Add the line mentioned in the workaround to the bottom of the file
    user_pref("layers.acceleration.disabled", true);
  4. Start Komodo.

Thank you so much for the reply! But I am still out of my league!
What is the Komodo Profile folder?
how do you open the XRE/prefs.js file?
what is an example of another text editor?
Any chance you can walk me through this by phone?


I can’t do phone support, i’m sorry.

Click the link I shared. It explains.

Sublime text, VS Code, Notepad ++, etc.

The same way you open any other file in Komodo, but with one of the above mentioned text editors. Either drag and drop the file on the editor or File menu > Open from the editor.