Komodo and Big Sur (DO NOT UPGRADE)

@paul.blmp, pardonnez mon mauvais français mais c’est le meme solution pour version 11:

Salut Paul,
Je viens de réussir à le faire. Je vais te guider.
Etape 1: Aller dans la Bibliothèque dans le Finder
—> Appuie sur “command” + “Shift” (la flèche vers le haut) + “.” en même temps pour le voir
—> Il se trouve dans le fichier à ton nom (c’est à mon nom le mien, je t’envoie un screen)
Capture d’écran 2021-11-17 à 12.22.45|690x199

Etape 2: Va dans Application Support
Etape 3: Clique sur le fichier “Komodo IDE” et/ou “Komodo Edit” si tu as les deux (j’ai le fichier en double, ils sont différents)
Etape 4: Trouve celui qui contient “12.0” dans son fichier (fais le pour les deux apps Komodo Edit et Komodo IDE si tu les as tous les deux)
Etape 5: Va dans “XRE”
Etape 6: Trouve le fichier “prefs.js” et clique droit puis ouvrir avec “TextEdit.app”
Etape 7: Tu vas tout en bas et tu colles “user_pref(“layers.acceleration.disabled”, true);”

Sauvegarde et tu pourras utiliser parfaitement l’application après ça

1 Like

Merci @Panda_Z!

Same here. I am running macOS 12.4 (Monterey), and have applied this simple fix.

It DOES work!!!

Thank you for all those who’ve made this possible for us Big Sur and Monterey developers!!!


This patch DOES work for macOS 12.4 (Monterey). I’ve just fresh-installed v.12 today, and applied the patch. It works!!!

heh If all else fails, I can create a VM ISO of Mojave using VMWare if I need to… :wink:

I am actually running OS 12.5 Beta, also works and also just purchased an M1 Pro based MacBook Pro, running good on it. By the way, any plans for Komodo to be native on the Silicon based chips? Also just learned yesterday that OS 13 (Ventura) Beta is also out for beta testers (for Macs 2017 and later) but don’t know what new features are on it yet.

Now we have OS 13 and Komodo is still not fixed and not native to the Silicon-based chips.

Does Active State give up Mac users? No update over two years. I think it’s time to leave.

6 posts were split to a new topic: Komodo Transparent window on macOS 12.0 Monterey

Hey all, I’ve moved the comments about an issue on Monterey to a new thread as it’s a new bug.

To clarify why you’ve not seen any action on Komodo has finally been announced. Komodo IDE Retired and Open Sourced - Announcements - Komodo IDE & Edit | Forums

It was a quite long process to complete this, so apologies that it’s just being announced now.

If you have questions please post them to the linked post above or start a new thread to vent. Please do not post questions about Retired Komodo in this thread.

No updated or fixes will be coming from ActiveState but I will do what I can to help people find a new workaround and provide feedback where I might have some helpful knowledge.

Sorry to be the bearer of bad news. I hope I didn’t just ruin your day.

  • Carey

Mac OS 10.14.6 Mojave. Komodo IDE 8 crashes shortly after file editing begins.
Any solutions?
Can I revert to an older version of Komodo somehow? Or would that work?

@Lowell_Levinger, there should be plenty of information here to figure out if your issue is the same as this thread reported (and semi solved). If it’s not the same issue then please start a new thread.