Komodo and Big Sur (DO NOT UPGRADE)

Had to use it again on Komodo Edit 11 and MacBook Pro… worked like a charm.

Thank you all!

1 Like

I am seeing the same spinning wheel as mentioned earlier in this post. I could start trying the workarounds but I also noticed that Komodo Edit 12 (which I downloaded) seems to only be supported on Intel, and I have an M1 chip. Is anyone able to run Komodo Edit 12 on a MacBook Pro w/the M1, on Big Sur? (recognizing that it’s still not an officially-supported OS by ActiveState.)

@henrya, apparently the M1 process has a translation “layer” or something (Processor design isn’t even remotely my strong point) that allows it to run x86 instruction. I guess that also means it can run x86_64 instructions.

ref: https://www.toptal.com/apple/apple-m1-processor-compatibility-overview

Having said that, if it wasn’t going to work, Komodo wouldn’t have started at all. You would never have made it to a frozen Komodo + beachball.

So, all THAT is to say, give it a shot and let us know if it works!

  • Carey

thanks…I should have searched a bit more, on https://www.toptal.com/apple/apple-m1-processor-compatibility-overview I just found this tidbit about the M1:

  • It features Rosetta 2 dynamic binary translation that allows it to run x86 software.

On to the workarounds.

@henrya, jinx. You owe me a beer.

  • Carey

2 posts were split to a new topic: Komodo Won’t start on OSX BigSur

Hi Carey,

It has been now about 7 months since Apple came out with Big Sur (not mentioning pre-releases available to developers). Is there a projected time for a Komodo release upgrade compatible with the current OS?

@Andrea, there is no plan to update Komodo to work any better on the latest OS than it currently does.

Worked great. Only difference is I’m using edit, so path is ~/Library/Application Support/KomodoEdit/12.0/XRE
Thank you for this.

1 Like

I’m using an old version on Big Sur, and I just get this silly window title glitch.

I’m not sure what to think of this. I cannot find a roadmap for Komodo IDE anywhere. The Big Sur bug exists for more than 6 months. @careyh mentioned there’s not going to be a fix ever.

Does it mean you expect users to stay on macOS Catalina forever? Or should they watch out for other IDEs straight away? I do need to have my projects in an in-house GitLab instance with CI and I need to be able to open files via SSH using my local key chain. This won’t work from within the ActiveState Platform. Yet as you built an IDE for the browser for the platform, you might be able to build an Electron app of it as well?

@marten, no, there is a very easy workaround. I run Komodo on the latest and greatest OSX.

This is absolutely possible. Is it you who has another forum thread open around this? Please link that and we can deal with that outside of this thread.

@marten, no, there is a very easy workaround. I run Komodo on the latest and greatest OSX.

The sticky note of this thread still states

At this time we advise that Komodo users remain on OSX 10.x.

And along with the layers.acceleration.disabled workaround you wrote

There are quite a few other issues apparent in Komodo on Big Sur so we’ll remain at “Don’t Upgrade”.

And with this bug report still open and no update of Komodo IDE available months later, it doesn’t look very tempting to upgrade :confused: The workaround alone surely doesn’t quality for a 12.0.2 release, but shouldn’t half a year of development work on other issues result in a new release?

Is it you who has another forum thread open around this?

No, I was only replying / writing about the Big Sur topic so far.

Hey @marten, yes, we officially don’t support it but if you read the thread most people are using it without issue with the workaround. Yes, there are other issues but from what I’ve seen the other issues are odd UI glitches.

I recommend you, and anyone else that feels like they have time, contact support@activestate.com and ask what the plan is with Komodo’s release. I honestly wish I could help more but I assure you I’m doing everything I can to help.

  • Carey

Yeah if you only use Editor the path is bit different, instead of …/KomodoIDE/… the folder is …/KomodoEdit/… the rest are the same. I just got this fixed on mine too.

However I do want to point out an interesting thing, how mine broke: I just purchased a newer laptop 3 weeks ago that already came with Big Sur and I just transferred Komodo Edit over from the old laptop (with High Sierra) and first Komodo worked for three weeks just fine. Then I tried to close the toolbox bar on the right side which started the spinning wheel and hung. I forced closed it and could never start it, even reinstalled it from a freshly downloaded copy would not get it going. Then I applied the fix which fixed it. I still wonder if it worked the first time why a fresh copy wouldn’t get it going again?

And I guess there will be no official fix for Big Sur as OS 12 is already on the horizon with BETA released so it’s not going to be fixed for just a couple of months. Hopefully there’ll be another official working release for 12.

Hey @Tibor_K,

As mentioned above, please contact support to request plans for Komodo future releases.

And regarding why you made it so long without hitting the issue. You likely never had a alert dialog pop up until you closed the toolbox. I can’t think off the top of my head which msg would have appeared due to closing the toolbox tab but once Komodo crashed, everytime you start Komodo a dialog would have tried to open to say “Komodo didn’t close cleanly, do you want to recover?”. That dialog (or any alert dialog) opening is what causes the crash.

  • Carey

@ssigwart Thank you

I can confirm that the workaround solved my issue :slight_smile:
If anyone’s having trouble just use the terminal, and your favorite terminal editor to update the prefs.js

  1. Fresh install of Komodo IDE 12
  2. Try to run the app
  3. Force close
  4. Terminal: nano ~/Library/Application\ Support/KomodoIDE/12.0/XRE/prefs.js``
  5. Paste user_pref("layers.acceleration.disabled", true);
  6. Save and exit
1 Like

Excuse moi mais j’ai exactement le même probleme avec komodo ide 11 pourtant j’ai le dernier macbook pro et j’ai juste pas fais la dernière MAJ es ce que tu as trouve une solution a ton probleme ?