Simplest way to change scrollbar thumb color for Komodo 10?


#1

Trying to use any kind of dark color scheme, the thumb (draggable box) within the right scrollbar becomes invisible against the dark background.

I did find a [Komodo X customization tutorial] (Komodo X customization tips & tricks). It mentions installing 2 add-ons, DOM Inspector and Element Inspector. However, after installing these add-ons, I don’t get the CSS rules option mentioned in the 3rd-ish step.

This posting mentions using the Stylish add-on to change the scrollbar color but Stylish isn’t yet compatible with Komodo X, apparently.

I tried using the editor mini-maps for scrolling which worked marginally well, but the width of the mini-maps changes (too fat or too thin) over time (at least with the split view panes) making their use inconsistent.

All I really want to do is change the thumb to a lighter color then I’m back in business.

In the meantime, I’m using a light colored background which is hard on the eyes.

Any pointers/tips/help would be greatly appreciated.


#2

Hi @tomwitt2,

Thanks for asking this. I was literally JUST about to split an answer from another forum post to make this a top level post, now I don’t have to do that :slight_smile:

The answer can be found here:

I’ve filed a bug for this since you’re not the first person to bring this up. Several people have asked about this including myself.

-Carey


Colour of expand > markers in interface
#3

Thanks @careyh.

This is exactly what I needed.


#4

Can you please just make this work out-of-the-box.

It seems like no-one at Komodo seems to understand that this is a major UI failure.


#5

That’s what the ticket is for. It’s planned for Komodo 11.

I would disagree that this is a “major” UI failure. It creates an issue on screens with lower contrast ratios is all. An issue that can easily be worked around by using a different UI color scheme. That said it IS an issue, one we intend to resolve.


#6

So, we have to wait for a paid upgrade version to fix what is a pretty stupid UI bug.

Your product, out of the box, has a failed interface on many screens. You could choose to fix it. Or you could choose to blame people’s equipment and then tell them to wait until you do a future version that they have to pay for.

Seeing as Komodo IDE v10 is so badly broken (codeIntel not working) that I have had to revert back to V9, I am seriously wondering what I get for my money with these updates. It certainly isn’t enhanced functionality, and it certainly isn’t good support.

The only reason I haven’t switched to a different development platform is out of my own laziness. Unless things dramatically improve with Komodo IDE and the support the V10 upgrade will be the last I ever buy.

And if there is not a fix VERY SOON for the codeintel failure, then I’m going to return my V10 key and ask for a refund.

Jolyon


#7

The problem here is not so black and white. First only users with low contrast monitors are affected, second it only concerns one single color scheme. You can easily switch to a different one.

That said, this isn’t a very complex problem either. The main reason I punted it to 11 is because the colors are all connected, changing the color for the scrollbars would change that same color everywhere in the UI, and I don’t like big changes like that in small releases. I will have another look at it for 10.2 though.

I’m not sure what you are referring to exactly with the codeintel failure, can you link me to the relevant thread/issue?

Also while I understand and appreciate your frustration I would appreciate if we could speak about your issues in a civil and kind maner. No one here is out to get you, we all want you to be happy.


#8

This is never true in any UI. If users with low contrast monitors are affected, there isn’t enough contrast and it will affect many people regardless of their equipment and monitor settings.

This is still an issue with Komodo 11. There is still not enough contrast between scrollbar thumb and scrollbar. Jolyon_Ralph had this one right in 2016 and is still right. There is no reason why the scrollbar thumbs should not contrast adequately with scrollbars. This should not require any tinkering on the user’s part. This: “Can you please just make this work out-of-the-box.”


#9

ps – This can be addressed by experimenting with the color scheme editor. By applying the “isotope” scheme to the Interface – check the “Interface” box after hitting Apply. I am still not sure why any of the color schemes hide the scrollbar thumb, but it’s more of problem with the color schemes (including the default scheme) than it is with komodo itself. The solution would be for komodo to fix the default color scheme.


#10

pps – I spoke too soon. Applying the isotope scheme makes the text in the left pane invisible. I know of no other software that ships with colors that don’t work and expects the user to experiment until all parts of the UI are visible.

ppps – I see the scrollbar is not part of the “interface,” but rather is part of the “editor.” I still have not found a decent combination of schemes that makes the whole UI easy to see.

pppps – Best option seems to be to apply the “classic” scheme to interface, editor and widgets.


#11

Hey @arnoldbird,

We addressed the reported bug quite a while ago. This thread has been quiet for 3 years so it would appear that it hasn’t been an issue for other users (or they just haven’t said anything).

If there are issues to report, please file new bugs:

You’re feedback is appreciated.

  • Carey

#12

For what its worth, I changed the color of the scroll thumbs in my color schemes.
The less I’m using:

scrollbar {
    thumb {
        background: darken(@background, 3%) !important;
		opacity: 0.5;
		transition: all 300ms ease;
		&:hover,
		&:focus,
		&:active {
			opacity: 1;
		}
    }
}

dialog, :root.dialog, :root.pref-window {
    scrollbar thumb {
        background: darken(@background, 3%) !important;
		opacity: 0.5;
		&:hover,
		&:focus,
		&:active {
			opacity: 1;
		}
    }
}

#commando-panel {
    scrollbar thumb {
        background: darken(@background, 3%) !important;
		opacity: 0.5;
		&:hover,
		&:focus,
		&:active {
			opacity: 1;
		}
    }
}

:root.special scrollbar thumb {
    background: darken(@background, 3%) !important;
	opacity: 0.5;
	&:hover,
	&:focus,
	&:active {
		opacity: 1;
	}
}