Node.js not following global tab rule

I set the tab spacing to 2 spaces in the global config, and even set it individually for both JavaScript and Node.js and Node.js still insists on using 4 spaces. JavaScript works fine, but Node won’t. Is this a bug or is it just my unfamiliarity with Komodo?

Did you setup tab spacing for Node.JS manually before setup tab spacing globally?

No. Global first.

As a feature request, it would be very nice to have a a checkbox next to the Language specific selector that indicates if the language is using the default (global) settings. This would allow me to make sure that Node.js and JavaScript are in the default mode.

@toddw can you look at it?

It appears I can’t change either language now. I have tried restarting the IDE, but to no avail. Node sill has 4 spaces, but I can’t get standard JS to follow suit. I’ve again changed the setting in both the global and language specific areas.



Ok I found a partial solution, maybe the source of the problem. My .editorconfig had been changed by the updates only once (to indent_size=2) and wouldn’t change back when I changed that setting in the preferences.

I changed that and restarted the IDE and it works as expected, but the original issue of Node not following that global rule still exists. I can confirm that I did indeed change the individual setting for Node as well and it still didn’t affect it. I guess this is a bug now, unless there’s still something I’m missing?

Note your files can have individual settings, perhaps some of the files have gotten their indentation settings saved on them? To check this right click on the files tab and select File Preferences, then check the Editor > Indentation prefs in the window that pops up.

I moved a post to a new topic: Node.js status