No Python interpreter could be found error, tried everything


#1

Hi there,

I have Komodo Edit v9.0.1 nightly and Python 3.4.3. Both were downloaded from their websites this morning (27 April 2015) and installed on Windows 7 64-bit without issue.

I added the C:\python34\ path to my user path system variable and verified that it shows up as set correctly if I run echo %PATH% at the command prompt.

In Komodo Edit > Preferences I also checked the path shows correctly in Environment, I set the *.py file extension to the Python 3 language in File Associations. Specified Python3 as the default language in File Opening. Python3 is selected under Languages and Find on Path is set in Languages > Python 3. Under Windows Integration the .py extension is added for Default Editor and Edit with Komodo.

I created a new project in a folder on my desktop (there are no spaces in the path to this directory, nor in the project name). I added a file to the project from template, selecting Python3 as the type and using the .py extension.

The file automatically had the correct shebang in it and I added a simple print instruction to yield a file contents of:

#!/usr/bin/env python3

print("Hello")

I added a command to the toolbox with a name ‘Build Python’ and the command %(python) "%F" with nothing else in the command box selected or ticked.

When I double click the command in the toolbox pane, or attempt to run it using a key binding I receive the following error:

Error running command [Build Python]: This command string includes ‘%(python)’, but no ‘python’ interpreter could be found. You can configure this by visiting the Python preferences panel in Edit->Preferences.

Python works fine from the prompt and IDLE.

I have attempted this on a separate Windows 7 32-bit machine also, with the same result. How do I make the darn command work?

Thanks

EDIT: Also now tried adding PYTHONPATH environment variable. No change.
Also tried altering the command through the following permutations
"%(Python)" "%F"
"%(Python)" %F
%(Python) -u "%F"
"%(Python)" -u "%F"


No Python interpreter could be found error. Round II
#2

Have you checked Prefs > Languages > Python 3, as the error suggested?


#3

Hi Nathan,

TBH, the message doesn’t actually state Prefs> Languages
It states Edit->Preferences which is a much wider gamut of possible incorrectness! :smile:

As I OP’ed

Is that what is meant? Specifying the location of the interpreter directly here rather than indicating to use the path makes no difference to the error.
Should I have items added in the ‘Additional Python 3 Import Directories’ box?

Python (sans ‘3’) is not selected on the Primary Languages list nor does it have an interpreter location specified, is that OK?

Ta, T


#4

Ah now I see the problem; you’re using %(python) where you want to be using %(python3).


#5

D’oh!!

Thanks Nathan :smiley:


#8

life saver