Komodo edit crash when loading

installed Komodo edit version 8.5.3 on Window 7 platform.

when loading, program crash immediately.

The message is:

We’re Sorry

Komodo Edit had a problem and crashed.

can anyone help? any items need to configure?

I have python 2.7 installed.

Have you used any previous versions of Komodo?

Could you provide your error log? This should be located at: C:\Program Files\ActiveState Komodo [IDE|Edit] \8.5\pystderr.log (see below)

have install the IDE, it crashed, then install Edit version, it crash as well.

there are no error log mention, btw there are no folder structure with
C:\Program Files\ActiveState Komodo [IDE|Edit] \8.5\

what is installed is
C:\Program Files (x86)\ActiveState Komodo Edit 8
ko.exe
komodo.exe
LICENSE.txt

C:\Program Files (x86)\ActiveState Komodo Edit 8\lib
4 folders: mozilla,python,sdk, support

Those are “all” the files that are installed? There should be a lot more …

What method did you use to install?

1 Like

In Linux i have as many files.
( /opt/Komodo/bin -> 1 file (komodo), /opt/Komodo/lib -> 4 folders (mozilla, python, sdk, support), /opt/Komodo/share -> 1 folder with icons and “doc” file). In Windows a lot more files and folders?

below the 4 folders ( mozilla,python,sdk, support) includes all the files installed:

what I am referring to is that there are no folder "8.5’ with any pystderr.log file you mentioned.

quote" Could you provide your error log? This should be located at: C:\Program Files\ActiveState Komodo [IDE|Edit] \8.5\pystderr.log"

Because file “pystderr.log” located in C:/Users/{Profile}/AppData/(?)/Komodoedit(ide)/8.5". (wrong, @nathanr says correct path below) OR “~/.komodoedit/8.5/” (Linux).
And you can use “Search” in Windows to find pystderr.log.

1 Like

Ah my bad, I gave the wrong path. The correct path is C:\Users\<user>\AppData\Local\ActiveState\Komodo[IDE|Edit]\<version>

1 Like

Hi Nathanr,
the file pystderr.log is empty.

Does it give you any useful information when you check “Tell ActiveState about this crash…” and then click “Details” ?

I am having the same problem on Windows 7 64-bit. It installed. It crashes when tried to run. I have python 2.7 and python 3.4 installed on my computer however shouldn’t it be looking for python 2.7 under ~\Komodo\lib\python? There are the four directories under lib that you have been talking about: mozilla, python, sdk, and support. There are plenty of files under those sub-directories under the sub-directory lib. By the way, I do not get any errors. It never gets going.
Thank You,
Micah

This is marked as “resolved” but I’m not seeing the resolution? I also have this problem – Windows 7 (64 bit), Komodo Edit crashes almost immediately, no splash screen or program window ever appears.

I actually had this problem before and found a work-around, but apparently didn’t document that. After wiping out my system and reinstalling everything, I’m back to not being able to use Komodo Edit.

Today I tried uninstalling, deleting all relevant folders in AppData, downloading a fresh install file, and reinstalling, but it still fails. The pystderr.log file is empty (0 bytes), as is pystdout.log. There is a startup-env.tmp file, though, that is not empty. I found it interesting that there is a reference to my VirtualBox installation location in that file…?

@ilikesci, @CampfireStu, you guys should post this data here:

I’m not sure if it’s useful, but the following shows the contents of the Details dialog from when I tried it just now:

AdapterDeviceID: 0x1244
AdapterVendorID: 0x10de
Add-ons: 
AvailablePageFile: 12059865088
AvailablePhysicalMemory: 5024489472
AvailableVirtualMemory: 4026621952
BuildID: 14424
CrashTime: 1422782888
EMCheckCompatibility: true
InstallTime: 1422753589
Notes: AdapterVendorID: 0x10de, AdapterDeviceID: 0x1244, AdapterSubsysID: 00000000, AdapterDriverVersion: 9.18.13.4475

ProductID: {b1042fb5-9e9c-11db-b107-000d935d3368}
ProductName: Komodo Edit
PyxpcomMethod: {db242e01-e4d9-11d2-9dde-000064657374}::observe
ReleaseChannel: release
SecondsSinceLastCrash: 28876
StartupTime: 1422782886
SystemMemoryUsePercentage: 41
Theme: classic/1.0
Throttleable: 1
TotalVirtualMemory: 4294836224
URL: 
Vendor: ActiveState
Version: 8.5.4

Can you test Komodo IDE 9 beta for this crash?

I will try when I get a chance.

I found my work-around, and this may be helpful in analyzing the problem. First, refer to this old info: http://community.activestate.com/node/9912

Since that was my reference before, it triggered my memory of what I had done to get things working, so my steps this time were more efficient:

  1. Start Komodo Edit with --raw -safe-mode
  2. Open a file (I chose a text file; it should be something that can be “previewed in a browser”)
  3. Preview the file “in a browser” but set it to open in a Komodo tab
  4. Replace the file address with about:config to get into the settings
  5. Make the two value changes mentioned in the post linked above
  6. Close Komodo Edit, then restart it without --raw -safe-mode

As I understand it, this decreases performance, but something is better than nothing. :slight_smile:

Well at least that tells us its related to graphics acceleration.

Please give the Komodo 9 pre-release a try when you can, I suspect the issue is in the mozilla version that Komodo 8 uses.

Finally had a chance to try it. No go, but different results. It crashes during launch, no program window or splash screen, but instead of the ActiveState crash reporter I just get the standard Windows dialog, telling me “ActiveState Komodo has stopped working” and giving me the option to check online for a solution or just close. The “problem details” – in case that info is helpful, even if not relevant to the problem discussed in this thread – are shown below.

Problem signature:
Problem Event Name: APPCRASH
Application Name: komodo.exe
Application Version: 9.0.0.0
Application Timestamp: 549a17d5
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521ea8e7
Exception Code: c0000005
Exception Offset: 00038e19
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I forgot to mention that the way I found (again) the thread that helped me with the work-around the first time was by doing some Web searches on the info in the Details dialog of the ActiveState crash reporter when Komodo Edit crashed. Those took me to discussions about Mozilla, and that triggered my memory of the work-around. I don’t know if that helps confirm the Mozilla connection, but I figured I’d mention it.

Could you try running Komodo with a clean profile?

For instructions see:

Scroll down to “Overriding The Profile Folder Location”