Komodo 11 - lagging on Max OSX


#1

Hello I’m upgrading Komodo Edit 10 to Komodo IDE 11 (trial period for now).

I have problems with lagging of all IDE during using it. I tried to switch off code intelligence and other automated processes with no change. After some time IDE becomes almost unusable.

At same time I’m able to use Komodo Edit 10.2 without problems.

I have Macbook pro with 3,3 GHz Intel Core i7 and 16GB ram running Mac OS 10.12.6.

I would be happy for any advice before I need to pay for it.
Thank you very much.

Petr.


#2

Hi, is your “Places” folder pointed at your home directory or other enormous directory? Try pointing it elsewhere or at a project folder.

Also, try temporarily running Komodo in Safe Mode (Help > Troubleshooting > Restart in Safe Mode) and see if that helps. If so, there’s something in your old profile causing the slow downs.


#3

What did you exactly mean by “Places” folder? I have no directory by this name at my mac. Is it some link?

I’ve already tried safe-mode with no luck.
And I didn’t upgrade my old version, I installed new instance from scratch.

P.


#4

The “Places” folder is the root in Komodo’s left pane.


#5

Oh, I see, sorry.

“Places” folder points to project root directory. There are 2048 files in all subdirs in this directory.

P.


#6

Hi, is your project under source code control? (e.g. Git). If so, you can try disabling SCC integration to see if that is the cause. Edit > Preferences > Source Code Control > [X] > [X] Integration (it’s a checkbox).


#7

Hello again.

It seems working correctly after disabling SCC, I was using subversion.
I will let you know after more time using these settings.

My last question is about possibility to commit changes directly from IDE. I don’t need online checking changes, but possibility to review changes on request and commit option will be great.

Thank you very much for you quick support.

Petr


#8

Please try to adopt the “Project” mechanic in Komodo. You should be pointing Komodo at the files you are currently working with. Doing anything else will be giving Komodo a substantial handicap.

You can do this via the version control widget in the bottom pane. Although obviously you’ll have to enable SCC for this.


split this topic #9

A post was split to a new topic: Komodo UI stops responding after interaction


Komodo UI stops responding after interaction