Komodo UI stops responding after interaction


#1

Hi, I have a similar problem to Bossacek (Similar Mac OSX and specs) and find Komodo 11 really slow when multiple files are open. Code autocomplete stops working and I am often made to wait for some background task with the wheel of death. I looked in preferences and cannot find a section called Source Code Control. It exists in Komodo 11 IDE but no checkbox and the select menus only work once. This is the same with Commando “Go to Anything” in both apps. I only works once per app launch. After that no visual response. If I use the old keyboard shortcut of cmd-shift-o the dropdown list does not appear but if i type in part of the name of a file in my project and press return it will still open the file so it seems to be listening but not iving me any visual response.


Komodo 11 - lagging on Max OSX
#2

@Nick_Dale, I’ve moved your question to a new thread as it’s not the same as the thread you posted in. Please clarify my questions below.

Can you reproduce this issue in Safe-Mode? Help > Troubleshooting > Restart in Safe-Mode

What exact version of Komodo? Help > About Komodo, on OSX Komodo > About Komodo.
What OS are you running and what version?

These two statements are contradictory. Please clarify.

“In both apps”? What apps are you talking about? Are you running two Komodo’s at once?

Your issues MIGHT be related to this ticket:

I’ll hopefully be releasing a “nightly” soon that will include that fix.

  • Carey

#3

Thanks Carey for your response. Apologies, I have been busy on a project and this is my first chance to reply.
By “both apps” I mean Komodo Edit 11 and Komodo IDE 11.
Komodo IDE, version 11.1.1, build 91089
The version of Komodo Edit is Komodo Edit, version 11.1.1, build 18206
platform macosx 10.14.3
I haven’t had a chance to try safe mode yet but the main issues are the select menu’s don’t work after the first use. This is apparent with the “Go to Anything” menu.
Also I get serious delays when multiple documents are open. I often have a few Find All lists open as well if that helps you at all in trying to test this issue.
I hope this helps because I have used Komodo 8 for years and really enjoyed it but now I’m having too many delays.
Best wishes


#4

For the menu’s not working I think the nightly will fix it. Find that here:
http://downloads.activestate.com/Komodo/nightly/

Regarding the serious delays:

  • Do you have a very large project that Komodo is scanning for code intel? This isn’t new. Code Intel has always had an effect on performance when it’s first indexing. A very large project exacerbates that but even initial creation of the code intel DB can cause delays.

  • Do you have remote files open? Certain functionality doesn’t run async so could be causing delays.

  • Do you have Version Control enabled? I believe there is a known issue with some Version control tools that have cause delays in Komodo, i’d have to look for more info on that.

See if any of the recommended steps in the following post help and report back on what does help:
https://community.activestate.com/faq/how-improve-komodos-editing-performance