KE9 Indentation

I’ve set the Preferences to use spaces and not tabs for indentation. When I open an existing file that has used tabs instead of spaces for indentation, how do I configure KE9 to override this so that when I re-indent a section of code it will convert it to spaces (not tabs)? I’ve done this in the past, but since my recent reset of my settings, I cannot find where it is. Can you help?

I’ve tried the Editor > Indentation > Allow file contents to override Tab and Indentation settings. But this seems to do nothing.

It appears that even though I have it configured to use spaces (not tabs) that it will use tabs on files that were previously built with tabs.

Where do I find the “per-file indentation preferences” ?

Found it under Edit > Current File Preferences. Changing here has fixed for this file. Will I have to use this per-file preference on all files that were previously created with tabs?

@ziplizard I believe we covered this already in another thread you started: Komodo Edit 9.1.0 Indentation Problem

Make sure you disable this.

EDIT: Once again, I would recommend you read this FAQ on Komodo Indentation settings as this is the second forum post you’ve opened on the topic.

  • Carey

A post was split to a new topic: How to changes tabs to space on save in Komodo