How to set "Track changes insertions" color in v10?


This is the color of the bar in the left editor margin for insertions. In v9.3.0 I could set this color in Color Scheme/Colors. But I can’t seem to find a corresponding setting in v10.1.0. This is a problem because the insertion color in v10.1.0 seems to be black while the margin background is grey so that insertions are indiscernible. I could set the margin background color (Color Scheme Editor/Editor/Line Number Margin), but I’d rather set the insertion color. Is there a way to do this?

v9.3.0 screenshot:

v10.1.0 screenshot (Line Number Margin=white: don’t want this):

Help appreciated, thanks!


Start by opening up the Color Scheme Editor (Tools > Color Scheme Editor). Then;

For the white background:

Find and select “Line Number Margin”, change the color there and then do the same for “Fold Margin”.

For the change tracker colors:

Change the dropdown selection on the left to “Interface”, then find and change the “Source Code Control” colors.


Thanks, that works!

A few comments (please correct/comment as necessary):

  • I need to check only Editor and not Interface when I apply the settings, otherwise I seem to lose my Interface color scheme and things looks really bad.
  • It seems I need to restart Komodo for the changes to be applied
  • I wasn’t sure what the different options mean in the color scheme editor but I think I’ve got it now. New means this is totally new line and Modified means you’ve modified an existing line. Is that right? Here are some screenshots:

Thanks again!


Things looking bad depends on the color scheme you’re using and how you’ve set it up, that’s not something we have a hand in.

Komodo does apply the changes instantly but for various reasons you may require a restart for all the changes to propegate properly.

That’s correct :slight_smile: New means something was added, modified means something that existed was changed.


Excellent, thanks so much for the very detailed help!


Komodo edit 11.1
I tried change color? but this take no effect.
I tried i 11.1 10.1.4 10.2.3 No effect!
New line always is green, changed — blue.

Apply misc color schemes take no effect



You likely didn’t apply the colour scheme before closing the dialog. Sorry for the obscenely late reply.

  • Carey