Hover tooltip lose focus problem

when I try to use hover tooltips to show a variable . it seems I need to put the mouse point 3 lines above the variable , then the vale of the variable will show up. seems the mouse 's coordinates has not been correctly calculated in the komodo debugger.

What OS are you on? Anything about your setup that could be considered as non-default that might impact this behavior?

If you’re using Windows, you might want to try using the latest Komodo nightly build here:
as that has some fixes to be able to handle Windows DPI changes (Windows appearance font size changes).

I use windows 7 system. I just tested the latest KOMODO, Komodo-IDE-8.5.4-85928.msi
the problem still exists.
see the image: when my mouse is one line above $dir, the value show up. that’s not good.

I have not do any special setting/configuration.

Just to double check the version - can you open the Help > About Komodo dialog and check that the build number is 85928.

I got these info:

« license info
Licensed to Yonghui Wang (Commercial license, serial number S43072910C).
« build info
Komodo IDE, version 8.5.4, build 85928, platform win32-x86. Built on Tue May 13 01:01:57 2014.
copy build info

Hi all,

I have this version:
Komodo IDE, version 8.5.4, build 86686, platform win32-x86.
Built on Thu Jul 17 01:07:54 2014.
and I still have the same problem.
How to fix it? it’s quite annoying :confused:


the build we can get so far in the latest section is not fixing the problem, whereas the 85928 it does.
How can I get that version?

Are you using a HiDPI (High DPI) monitor by any chance? If so could you try @Defman21’s suggestion here: High DPI mode

I am using HIDPI, following suggestion does solved the problem
my current resolution is 1440*900
following this calculation:
sqrt(1440^2+900^2)/13 = 130, after I set my
HKEY_CURRENT_USER\Control Panel\Desktop\logPixels value
to 130 decimal, the komodo works good.

you must change DPI in Windows.
To do it, you can read this: Change DPI on Windows11
I recommended “OPTION TWO” in this guide, because you can type a normal value, not percent.
Your dpi: sqrt(3200^2+1800^2)/13 = 282

Thanks for letting us know. We’ll try to have this fixed in a nightly.


thanks for your kind answers.
In my laptop monitor i have 1920*1080 resolution, so, applying the formula you gave, I get 169 which is a quite large value for DPI in windows… all the icons become so large

Komodo 9 is DPI aware, but Komodo 8 is not…

Try using the Cupertino icon set, this is the only iconset that is compatible with HiDPI monitors at the moment.

You can also try the Komodo IDE 9 pre-release here - http://komodoide.com/download/#preview

Thank you again for this reply, i just wonder whether my license is good to make komodo 9 run.
I just bought a komodo ide license last week, the one for one developer.

Hi all,

I have tested both cupertino icons and komodo9 release and none of them is working fine with this problem.

For all who use my formula - “13” - is your Diagonal!!! It’s not a fixed value. You must change this on your value or this formula give you a bad value.
Also you can use this site to get your DPI: https://www.sven.de/dpi/
Sorry if I confused somebody with this :smile:

Thank you very much!
my laptop is 16 inches so the formula gave 137.
I applied this and it worked but… there is a but!
In fact, when I change the DPI with a so large value, all the fonts on komodo window appear blurry.
I have to uncheck the checkbox “Disable display scaling on high DPI settings” in the compatibilty tab of komodo.exe property page.
When I do this, the look&feel appears fine, but again, the hovering is not working.

It seems we need a fix from active state in order to sort things out…

unfortunately, I make another test, using the calculation to get my dpi, actually this solution does not solve the problem!

Unfortunately I don’t know another methods to solve your problem, guys. Use IDE9 when HiDPI was supported.