Disappointed in Komodo 11


#1

Just purchased Komodo 11 and now am finding it inferior to Komodo 10.

1: Symbol pane (replaces code pane on right. Everytime I try to list the subs in a file I get a message that there are too many symbols to process eficiently. It will load anyway, but it is slow and a nuisance.
2: Hovering over an element to get its value is useless. The value appears for about 0.1 seconds.
3: The color scheme whereby elements in the Watch panel is terrible, just as in Komodo 10. Once the value is changed by the code, the font changes color to a dark color that is unreadable againse the gray background. I have found no way to correct this.
4: I have found none of the new “features” of any real use. The only good thing so far is that it doesn’t seem to be crashing as often as Komodo 10 did.

Not a happy customer.


#2

You could increase the max file size, but beware that the larger the file size the more it will impact performance. This was the same in Komodo 10 except that it would happily scan huge files without any warning.

To increase the max filesize run the following code from your Console widget (bottom panel):

require("ko/prefs").setLong("codeintel.symbollist.max_filesize", 100000);

The value is the number of bytes.

Can you elaborate; what element are you hovering?

Are you using the default color scheme? If not, what color scheme are you using?

I’m sorry to hear that. While we’ve had a lot of people come back to us and say they love this update we cannot always please everyone.


#3

4: Also, cannot get color editor to open consistently. It opens maybe 1 in 10 tries. Often it gives a message wanting to know if it should save your preferences first. It doesn matter whether you answer yes or no, the result is the same, the color editor fails to open.
5: Cannot consistently get the symbol browser in the right pane to open. the {} that is supposed to appear near the tools is absent.
6:Komodo does not rememberr the file type preferences from Komodo 10 projects. You have to either respecify the type for each file or define new defaults based on file extensions.
7:Clicking on the Show Symbol next to the file name can take 5 seconds in some of my libraries. I used to be able to keep the entire list in the right pane and click on the method I wanted to access.


#4

1: No I cannot even find the icon to get the method listing at all.
2:If I hover over a variable in Perl the value is displayed for perhaps .1 seconds, not long enough to check its value.
3: Using standard color scheme. When the code changes a variable in the watch pane of the locals pain the line in question changes color to something with very low contrast to the gray background. It is illegible, at least to me. To read it I have to click on the line so it changes color. This renders the watch pane almost useless.


#5

I’m confused, if you cannot get to the method listing how are you running into limits with it?

Are you talking about the debugger?

It changes color to red for me and is still quite readable on my screen, are you seeing something else?

Please try using Tools > Color Scheme Editor instead. If you can reproduce the issue raised here also consider filing it on our bug tracker.

This is strange. Can you see if you can reproduce this issue through Help > Troubleshooting > Restart in Safe-Mode

I’ve logged a bug for this here:

That’s the symbol browser, which you seem to be having some difficulties with.


#6

On the color issue, this is what I get when I first define a watch:
1: I found it earlier, but now it is gone,
2:yes, but it is unpredictable. Sometimes it works but at others the value flashes for only about .1 seconds
3: Yes it turns to red for me as well, and for me it is almost impossible to read. Can I change the color?
4:Still won’t open
5:Still MIA
7:No missing the Show symbol fir files. Thus have no access to symbol browser.


#7

7: Tried restarting in safe mode and the {} symbol is back, but restarting in normal mode it is MIA
8: Is there any way to change the Show Methods for a file to display methods alphabetically as can be done in the right pane (when it works)?


#8

8: Show icon appears for some files, not others. I have .cgi files and .lib files. Both are defined as PERL. THe sho icon appears only on the CGI files. Why?


#9

I posted a number of replys in thi discussion. For now I am going back to Komodo 10.


#10

I’m sorry for the inconvenience @DEklof, but this topic is becoming very difficult to keep track of. We’re talking about various issues unrelated to one another and I can’t really quite tell anymore which response is to what. Would you please open a bug on our bug tracker for the individual issues you’re experiencing (one for each)?

Frankly given the amount of issues and the symptoms of some of them it sounds like you may have a corrupted profile folder. I would recommend you try and start Komodo with a clean profile and see how that goes:

http://docs.komodoide.com/Troubleshooting/How-do-I-Start-Komodo-with-Default-Settings


#11

I’ll try that when I have time, but for now I need to do some real work on my project and as I said earlier, now that I have purchased Komodo 11 I haven’t found any compelling reason to use it so I am back using Komodo 10.


#12

I’m very sorry to hear that. To be very clear I am more than willing to help you with your problems, it’s just that I can’t keep track of them anymore via this medium. Again I apologise for the inconvenience.


#13

Komodo team again do this…
Released new version with minor changes, new critical issues… only for “get money on upgrade”.
After this poing no fixes for old version (v10, v9) also for critical issues (in bugtracker all issues will changed milenstone to 11)…
Just as quick example my issue from IDE 10: https://github.com/Komodo/KomodoEdit/issues/2652

Team… change the sales model to SUBSCRIPTIONS if you want money.
OR KEEP SUPPORT for old versions!


#14

I get more and more disappointed, too. :confused:
I have used version 11 for three days now and i am tempted to switch back to version 10, although it wasn’t the stablest version itself.
I am using Komodo IDE since version 5, i guess.
Since version 9 i think about to cancel my subscription and change to another “better” IDE.
All the mentioned features for new versions sounds so promising and usefull, but the IDE gets more and more unstable and feels so … “not ready” at various points.

Hoping for the best.
Maik


#15

We have subscriptions, you get the option for them when you buy Komodo. After purchase you only pay a certain amount per year. And you get 24hr guaranteed support to boot.

I have yet to see what I would call “critical issues”, and most issues that have been found are currently fixed in our nightly or will soon be fixed, and a 11.0.1 release will follow.


#16

Yeah, the price is x3 the stability is /3 :frowning: I’m very sad about ActiveState unreasonable new prices (I can buy Windows 10 for this money not only an IDE), I have to switch to PHP Storm. Their prices are reasonable, and they offer the same services like Komodo IDE 11. I wanted to keep Komodo IDE because I liked the spirit of it, but that spirit just disappeared.

  • I think ActiveState should take care their loyal customers, not punish them after years of loyalty.

PHPStorm is 89$first year, then it going to so much cheaper after a year. This is same I should pay 3x price after years of loyalty.

+The behavior of Sales support is very-very-very unacceptable, they communication very aggressive, rude. I got several insults right after my second answer. I couldn’t believe it how is a customer support let this behavior its workers.

When Komodo IDE was young I tried to help with my press connections and social channels, I gonna do the opposite of from now.

Bye, Komodo IDE I will miss you :frowning:


#17

The price is the same it has been. The only price that was increased is that of the individual option, and it only increased by 50%, certainly not 300%. Our upgrade pricing for individuals would be comparable if not downright cheaper than a yearly subscription to PHPStorm.

I have tried to get you to contact sales which is where these concerns are best addressed, but it sounds like you are unwilling to for whatever reason. We cannot help you if you do not wish to be helped.


#18

The NEW price of Komodo IDE was $89.00, I checked it.
The price of the upgrade was 59$!
Now the new price is 147$, and the upgrade price that I got from the sales is 147$ as well.
Sorry, I was wrong its only 2.49 times more expensive… still without any reason.
Komodo 11 is not a major update, there are only couple minor changes and new features, but as I can see in this forum the newest version is very unstable, the new autocomplete function buggy…

When I told everything to the salesperson about my past and struggling, he just offered the same price that I’ve found on the website, + he/she insulted me several times. He/she told me: It’s a same I couldn’t pay 147$ for a software… sorry that I wasn’t born in a rich country. People have to work 80 hours for 147$ here. I saved money for this upgrade, but I couldn’t save 147$, I supposed the 59$.

I’ve taken a lot of research on the weekend, and I switched to PHPStorm. They prices same like your old prices, their sales are very communicative and flexible (they answer right away not after 4-7 days), and the software is exactly the same, but PHPStorm a bit more powerful, and smoother.

So finally I can say thank you for Active State to pushed me to change to an another IDE, I can save money and time :slight_smile:

Thank you for your help here, the Komodo IDE forum was very cool, the issue is only on ActiveState’s side, not yours. You are still awesome, and I appreciate yours helps in the past.

Best regards,
an unsatisfied disappointed veteran Komodo user


#19

It really sounds like there was some miss-communication going on there. If ever you’d like to pick up the thread on this feel free to send me an email and I’ll make sure this gets properly routed. > nathanr@activestate.com.


#20

Six weeks since I posted this note. Since then 11.0.1 was released. Thankfully, K11 no longer crashes. Eureka! But I still have no code pane (hav3en’t tried safe mode since 11.0.1 was released) and the red on gray color scheme in the watch window is impossible for me to read. I haven’t found any way to change it…