Your komodoedit profile cannot be loaded ... missing or inaccessible

I recently reloaded linuxmint 17-64 bit on my desktop machine. When I tried to run my old version of Komodo Edit (8.?) I got a popup message box reading “Your KomodoEdit profile cannot be loaded. It may be missing or inaccessible.”

So I downloaded and installed KE as a tar.gz from this web site, installed it to my home directory (it installed as user root:root), and still got this error. Then I did sudo chown sadhu:sadhu for both the KomodoEdit and .komodo directories. I get the same error.

When I run KomodoEdit from the command line, I get this response

(process:24312): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(komodo edit:24312): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(komodo edit:24312): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(komodo edit:24312): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(komodo edit:24312): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
Error: Access was denied while trying to open files in your profile directory.

I can run KomodoEdit from the command line, if I run it as root. I’m not sure this is the best idea.

How do I get KomodoEdit to run properly?

BTW it runs just fine on my laptop, which is running Linuxmint 17-32bit



The fact that you can run KE as root proves that you’re experiencing a permissions issue. Try installing KE not as a normal user (not root) in your home directory and starting with a clean “.komodoedit” directory. Also, whenever you chown, please ensure the -R flag is set.

QED, as indicated by the console error messages.

Been there, done that, prior to writing the original cry for help. Note that I get the same response/error whether I install as root or as user, in the /opt/ or /home/sadhu/ directories Note that when installed as root, all files and subdirectories are owned by root:root, but I get the same error message. When I install as user sadhu, at first the directories were owned by root, but I did chown -R command and got the same result.

To recap: whether I install as root or as user, I get the same error box.

Whether I install as root or as user, KE runs when it is started by user root.

I saw another post dating from 2012, I think, which mentioned that the only way to recover from this would be to do a clean re-install of linuxmint.

It might be best to kick this topic over to the developers, or to list it as a bug, as the error, though rare, has cropped up before.



I discovered another hidden directory in my home directory: “.activestate”, which was owned by root. I did sudo chown -R sadhu:sadhu .activestate and now KE works as it should.

I still think this issue should be kicked over to the developers.

This ‘.activestate’ folder mus be created by python or somerthing…


There’s nothing that Komodo developers did wrong. You should never install Komodo with root, it may cause a lot of permission problems and it’s just too dangerous (about year ago I installed Komodo as root and it caused a lot of errors which made me remove anything related to Komodo and install Komodo again). root is root, you should use it when you want to change something in your system directly and Komodo isn’t something related to the system, OS, packages, etc.

You should install Komodo in your $HOME directory, use sudo in case if you want to fix your permission problems (because you won’t be able to change the permissions of anything if the owner of this “anything” is root) and don’t use root for installing programs which are not in your repositories.

The only one thing that Komodo developers did wrong - they don’t prevent installation by sudo/root. I’ve filed it as a bug:

This made me chuckle, considering it came from you :wink: Glad you’ve learned this :smile:

Note you do not need to install Komodo in your $HOME directory, you can install it in /opt or really anywhere on your system (technically) as long as your user has read permissions and execute permissions for the executable.

I disagree with you there, just because it’s bad practice to launch Komodo as root doesn’t mean there won’t ever be a use-case for it. But Komodo should ideally warn you that you are trying to launch it as root.

Haha :smiley: Yeah, it was a big mistake and I have learned that it’s not a good idea to install Komodo with root :smiley:

As long as you’re the only one user who uses the PC. If you have more than 1 account in your system - I don’t see any reasons to install Komodo to /opt/, I’m not sure that I can set more than one owner for Komodo instance. But it’s something specific, so… yeah, you can install it anywhere as long as you’re the only one who will use it :smiley:

I didn’t mean launch, I mean installing. For sure there are some use-cases when you would want to run Komodo as root, but installing it as root… I don’t see any cases for that.

Well actually, having more than one user on the system is the exact reason that installing to /opt is recommended. So all users can access it. To give access to multiple users you set the permission on the group level and ensure that all relevant users are in that group.

There is absolutely nothing wrong with installing Komodo as root (to eg. /opt), this is how I do it. It’s launching komodo as root that gives problems because you are touching user files as root.

1 Like

Ohh, forgot about groups in Linux :stuck_out_tongue:

And it won’t cause any permission problems?

Nope, it should install with the right permissions for users.

To be clear, you could run Komodo as root and as long as you only touch root owned files while running it as root you will be absolutely fine. It’s just error prone and unsafe to do that.

Okay, give me the latest answer.
I’m running Komodo as root and I’ve touched a file python.php created by the defman user. After I did some stuff in this file and saved it - python.php's owner is root now?

Just to clarify what I meant by “installing as root:”

After extracting the tar.gz, i can either type “./” or “sudo ./” (I’m running linuxmint 17.)

In both cases it defaults to installing in my home directory, and the owner of the directories is “root:root”. Which makes it a pain to manually edit the preferences xml file.

The reason I installed it to /opt is because I thought that’s what you’re supposed to do. I seem to recall that Firefox and xampp end up there. At least they used to.

I discovered that the .activestate file/folder doesn’t show up until you run KE. So the offending version of .activestate must have been there from a previous installation.