Xdebug: komodo on windows pc, webserver on 2. pc with linux


#1

Hi all, i hope for help and have done this:

  1. Setup linux on an old laptop.
  2. added mysql, apache, php
  3. added a virtual host
    everthing with 192.168.1.222
    added xdebug, edited the /etc/php/7.2/apache2/php.ini;
    zend_extension=/usr/lib/php/20170718/debug.so
    remote_enable=
    handeler=dbgp
    remore_mode=req ?
    remote_host = 192.168.1.1 (my workstation)
    port=9000
    autostart =1 (make problems?)

On my windows workstation i use komodo
php is installed; the xdebug.dll is added in php/ext

in php.ini local on workstattion i have
[XDebug]
zend_extension = “E:/XAMPP/php/ext/php_xdebug.dll”
xdebug.profiler_append = 0
xdebug.profiler_enable = 1
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir = “E:/xampp/tmp”
xdebug.profiler_output_name = “cachegrind.out.%t-%s”

xdebug.remote_handler=dbgp
;xdebug.remote_mode=req
xdebug.remote_host=192.168.1.222
xdebug.remote_port=9000
xdebug.idekey=adeva

(XAMPP is not running!, i want to try it with extern webserver)

When i call the page at the linux server with some ?something
komodo starts listening, we can walk trough the script for some steps; then i get an error that my local debugging is not configured.

What i can try else: check and download again both xdebug-files to be shure to have them from activestate;
change the php-ini local?


#2

prefs:
interpreter: php-cgi.exe
drush, i dont know, empty
composter > php.exe
conf file php/php.ini (if nothing here, no change)
php dirs i use the tmp from above?
xdebug.profiler_output_dir = “E:/xampp/tmp”
xdebug.profiler_output_name = “cachegrind.out.%t-%s”

Read in net:
Komodo creates and uses a php.ini file that it stores in your profile folder for this.
Done, nothing happens, still not configured

Should i change the komodo done php,ini?


#3

Anyway i dont understand why i need local debugging. I have mapped one time yesterday local files and webserver.


#4

Morning @anjade,

Thanks for the config info.

Could you plainly state exactly what is wrong? You said debugging works and you can step through your code so what is the issue?

  • Carey

#5

Sorry, i am not used with this type of forum. There should be a second thread now with more infos.
Five minutes ago i could use the breakpoints; then i changed them and now the debug doesnt stop there anymore. Then i restart the apache, restart komodo and now it seems to run again.

xdebug.cli_color=1
xdebug.collect_includes=on
xdebug.collect_params=1
xdebug.collect_return=1
xdebug.collect_vars=1
xdebug.default_enable=on
xdebug.extended_info=1
xdebug.idekey=“dbgp”
xdebug.max_nesting_level=100
xdebug.remote_autostart=1
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_host=192.168.1.1
xdebug.remote_mode=req
xdebug.remote_port=9000
xdebug.show_local_vars=1
xdebug.show_mem_delta=0

These is the last php.ini

One problem maybe was that the mapping needs fetched file = remote or local dir;
set breakpoints in the file remote or local like set up here.

My questions:
set breakpoints local or remote? It doesnt matter? Because komodo has access to both places.

Is there anything that disturb the system? It is better than nothing, but reload apache/komodo seems not to be comfortable :slight_smile:


#6

What did you change? Why did you restart the server?

Remote file. Komodo matches paths to breakpoints. You can set Preferencese > Debugger > Initial break behavior: Break on first executable line or you can set up Preferences > Mapped URIs.

I don’t understand this question. In normal circumstance you don’t need to restart Komodo or Apache if you already have your system configured.

  • Carey

#7

Somehow i have managed it. Most of times i can work with it. Sometimes i have to restart komodo.
But the biggest problem of all is:

Normally i press strg+f to write something to find in a field.
Sometimes this is not possible; then STRG+f opens a field, buit only as long i press strg+f; then i have to press alt+n.

This kills me; i need strg+f every two minutes.What can i do, what do i change?


#8

@anjade please start a new thread for your new question. It’s unrelated to the original post.