Write perl unit tests with Komodo-compatible output

Typically my projects are not modules and don’t require makefiles, but I put my packages under ‘lib’ and test files under ‘t’. I’ve tried many things and can’t seem to get my tests to execute with output that Komodo is able to parse. I’ve created a makefile with a test target that emulates what Ext::MakeMaker creates:

    perl "-MExtUtils::Command::MM" "-e" "test_harness(0, ())" t/*.t

Using Test::More creates output incompatible with Komodo’s TAP parser. In some cases a file with all passing tests is marked failed because output from the subsequent file with a failing test is parsed as output from the first file. In other cases a file with failing tests is marked “information” instead of failure and the detail lines start with ‘Unrecognized input’.

Is there something I should be using instead of Test::More to generate test output for Komodo?

Given the lack of response, should I have posted this in a different category? Did I leave something out? This is a pretty big feature of Komodo that seemingly never really worked for perl. Here is a relevant bug report created in 2009 that was reproduced by ActiveState in 2010. The bug was apparently slated for the 9.0 milestone but it has been resolved with status “expired.” Pretty frustrating. Besides creating a new bug report, what’s the best way to get attention from ActiveState on this issue?

Good to see that the bug has been reopened.

Hi there,

Unfortunately it is too late for us to address this in 9.0, but we’ll be sure to look into it for 9.1. I’m sorry it got closed due to automation.

I’ll move this thread to Support/Resolved as we’ll be tracking the actual bug on the bug tracker. Should we find a temp workaround we’ll be sure to mention it on there.