Word wrap long lines feature not available in v11.1?


#1

Does anyone know why the Word Wrap Long Lines feature isn’t available in v11.1 or, if it is, how to access it? It’s not in Preferences>Editor or anywhere else in Preferences. Even with Word Wrap enabled on the View menu, files previously saved with this enabled still open without wrapping. Long lines can be wrapped by deselecting and then reselecting the Word Wrap checkbox in the View menu.


#2

@hhitchcock, so it is working but the menu is broken, correct?

This sounds like a familiar bug that has been a huge pain in the you know what to replicate and therefore fix.

Oh I found the ticket, sounds like it’s easier than I thought to reproduce but has just been a low priority:

  • Carey

#3

Thanks for your response. The View menu item works fine - it’s just a nuisance to have to keep deselecting and reselecting to get words to wrap. Other sources indicate that the Preferences dialog used to include an option to make all files open with Word Wrap enabled and functioning. In fact, the user could select Word, Character, or None for this feature. My problem is that in v11 the option isn’t available in Preferences. I’m trying to find out if the option in the Preferences dialog has been intentionally removed, or inadvertently lost. Are you using v11 and is the option missing in your Preferences dialog?


#4

The setting still exists, it’s under Preferences > Editor (Expand it!) > Smart Editing > “Wrap long lines by”.


#5

Ah ha!!! You’re right, and thanks!


#6

Hello
I have the new version 12.0.1 and i cant find the choice Smart Editing !!


#7

hey @zoezoe,

smart-editing-prefs

Hope that helps.

  • Carey

#8

HOHOHO !!! 2 days i try !! Now i see the arrow in the left from editor,that open extra small menu !! Thank you very much my friend !!


#9

I got your back, @zoezoe.

  • Carey