Why is Komodo aligning to 8 spaces for tab?

There is only one , unindenting removes 8 spaces worth. I can’t figure out why this is happening. The per-file is also 4 spaces per tab/.

Note our preference UX needs some tweaking, at the moment there is no way for you to tell whether it is using file specific prefs or whether it is deferring to the global prefs. I’m sure it’s deferring. The way to change this right now (which I admit is broken and needs to be fixed) is to changed the indent value to a different number, hit Apply, and then change it to 4 (or whatever number you want).

If you want to use a different number than the one that is already entered then just entering the different number and hittin apply will suffice.

Note that Komodo 11 will have simplified and improved indentation detection.

Hi, it may be worth un-checking “Allow file contents to override Tab and Indentation settings”.

It took a few restarts, but It’s functioning normally again.
I have no idea how it got that way as I’ve never set 8 as a value.