Why does Komodo12.0.1 insist on install of xterm in state created virtual project?

Created virt project using state tool, now can’t run python curses code. Komodo insists on installing xterm. Installed xterm, now how can I find codes to change in xterm, so can make xterm more usable.

Morning @BartySlarph,

What OS?

And can you elaborate on this statement?

Komodo insists on installing xterm

What do you mean? How does it insist?

Forgot to include the OS, sorry. Using Kubuntu 20.04 LTS. Have coded a Python Curses program, won’t run when I use Tools/Run command.
Dialog that comes up says “no supported terminal was found, please install xterm”.

What shell do you have installed? Looks like Komodo knows about xterm, konsole, and gnome-terminal for Linux boxes. This sounds like a familiar problem. There should be another thread in the forums about this, not from you.

Will try again to find Threads, found none that came close last time I looked. Any hints?

No I can’t find it in our forums or in github.com/komodo/komodoedit/issues.

^^

Komodo shows Bash at /bin/bash, but kubuntu 20.04 uses Konsole. Tried setting Environment variable to Konsole, didn’t work, tried setting to xterm, works sometime an not other times. Have not tried gnome yet. Will try it.

@BartySlarph, can you try running the following code in the JS console and copy the results here:

var koSysUtils = Components.classes["@activestate.com/koSysUtils;1"].getService(Components.interfaces.koISysUtils)
koSysUtils.Which("konsole")

If it doesn’t find anything, maybe konsole isn’t on your path? (I have no idea if it SHOULD be. Not a heavy Linux user). Try adding the binary to your path and restarting Komodo from that shell where you edited your path.

Konsole comes up when you run Bash scripts or use Python in shell mode. No clue where JS console is,
can’t find in Komodo. Tried gnome-terminal, No good. Tried Konsole, Bash, Xterm. Only one that somewhat works is xterm. All these have executabes on system.

Search with state tool shows no konsole installable. Konsole is the terminal used by KDE plasma on all
KDE plasma based linux distro’s, I think.

View menu > Tabs & Sidebars > Console

Can you elaborate here? Run where?

Tried where? To do what?

This isn’t possible, yet. I believe it’s a goal later down the development road.

Thank you, found JS console, script replyed String “”. When I use bash or python scripts outside of komodo virt env Konsole comes up. Konsole is KDE Plasma’s terninal on Kubuntu. In Komodo virt env
tried gnome-terminal, konsole, xterm, bash, xterm sometimes works I think I to chage xterm setting to
get xterm to run right, bash, konsole work fine outside of komodo virtual env.

Forgot to add tried using gnome-terminal, Konsole, xterm from komodo virt env, set path in overfide default to each binary, set each as SHELL. Only xterm came up. Need terminal to use for curses programing.

It sounds like you might have blown away your PATH in Komodo. If konsole is available in a regular terminal session then it should be available from Komodo. Check Preferences > Environment and see if you’ve overriding your PATH. Check the same for Project level prefs as well (Right click on the active project and select Project Prefs). Please share a screenshot of the prefs.

If they aren’t overridden, how are you starting Komodo?

Success!!! Found problem. Did as you said, Changed /bin/bash to /bin/konsole in override defaults, now it works. Thank you for the help,!

1 Like

@BartySlarph, I was getting worried we wouldn’t get this, not gonna lie! Glad you got it!