Whitespace setting doesn't apply to newly opened files

Hi - I have an essentially fresh installation of Komodo IDE 12.0.1 and I’m trying to get whitespace to be shown consistently while using Komodo.

I am aware of and have changed settings in Edit -> Preferences -> Editor -> Show whitespace characters and the colour of the whitespace characters in Edit -> Preferences -> Color Scheme.

I can get whitespace to show on a single file, by opening the file, changing Edit -> Current File Preferences -> Editor -> Show whitespace characters.

Despite having the general Preferences setting for Show whitespace characters checked, opening a new file doesn’t show the whitespace characters and the setting is unchecked in Current File Preferences.

How can I get Komodo’s new files to open and inherit the whitespace setting from the general Preferences settings? It’s unhelpful having to enable it for every new file that gets opened.

Thanks in advance.

Morning @PNG,

Setting the global Edit menu > Preferences > Editor > Whitespace pref enables whitespace for any open and newly opened files for me.

Something that could cause an issue (other than a bug):

  1. Project preferences might be overriding global if you have a project open
  2. The files you are having the issue with maybe have previously had the file level pref set to disabled.

Fixing the first should be self explanatory.

The second point can be resolved by closing Komodo and deleting the doc-state.xmlc file from your profile folder. This post should help you find your profile folder:

  • Carey
1 Like

Hi @careyh,

Thank you very much for your reply.

I do think it was your second point - files previously opened had retained their own settings from before I changed the global settings. I reverted one manually, before taking your advice of deleting doc-state.xmlc, and that’s working well for me.

Thanks again for the support, and for Komodo!

1 Like