What broke my update?

Hi everyone. I’ve been working with Komodo edit for the past 6 years or so now. My setup is a Linux Mint (version 17.3) system and I use Komodo Edit primarily for family pages and some ebay related templates. To make things easier (quicker) I’ve developed about 25 or so custom templates, located under snippets and saved as a project KPF file. This worked wonderfully for years … until last week where everything was ruined.

Last week I noticed for the second time that after so many years it’s finally possible to update Komodo edit directly from within the Linux Mint repository with a single button click. The first time that I used this option a couple of months or so ago, everything went fine. Then last week, my entire Komodo Edit setup was ruined after upgrading.

It’s not an exaggeration. Everything was ruined. Komodo still works fine, but now I have this horrendously ugly dark theme by default. Black everywhere !!! Going into the settings in order to make changes … changes nothing !!! My custom profile settings are there, but clicking on them does absolutely nothing. If I try to change the colors manually, the themes will permit me to select a lighter theme, but no matter what I do after that … nothing changes. The default text is much smaller now as well for some odd reason. That’s not even the worst of it though …

First it took me over an hour to locate my most recently saved template files since those appear to have vanished. When I did find them in a TMP directory ??? and imported them for use, every one of them was totally different from what I used to use for my html pages. Now everyone of my templates has this on top:

“keyboard_shortcut”: “”,
“name”: “VERKAUF - 03 Fotos”,
“value”: [

followed by more at the very bottom, consisting of:

“set_selection”: “true”,
“version”: “1.0.12”,
“indent_relative”: “false”,
“type”: “snippet”,
“treat_as_ejs”: “false”,
“auto_abbreviation”: “false”

And to make matters even worse yet, all over each template file, from top to bottom, I have literally hundreds of apostrophe " marks that were never there before !!! They’re located on each and every line of my templates, all over the place. Some of my template files have in excess of 50 lines.

I have no idea what happened, but I would really like to be able to revert back to either Komodo Edit 9.3 or 8.5 where all of my templates and my theme settings worked correctly and showed up correctly on the screen. Can someone please provide me with a Linux Mint / Xubuntu / XFCE step by step to get this accomplished?

I don’t know who maintain the repository you mentioned, but I strongly recommend to download Komodo from the official download page.

Thank you, but that’s not exactly very helpful at this point. Komodo Edit informed me on the screen that an update was available the first time. This is something that obviously had to be coordinated somehow with the Linux Ubuntu or Linux Mint (based on Ubuntu) developers since the Update function via Linux wasn’t magically or inappropriately created by strangers outside of the system. The last update, the one that went kablooey, showed up in the update manager … again something that had to be coordinated directly between Linux Mint and the developers of Komodo Edit. The Linux Update Manager is supposed to be 100% safe with tested and tried results BEFORE they’re made available. So please don’t blame me for using the tools that were intentionally provided to me. Using the update manager is not like using third party Windoze Software, where you can only hope that the software is fine. The update manager is supposed to be totally safe … always …
You’re obviously not a Linux user. Someone somewhere screwed something up pretty badly … something that I’ve never encountered before.
What I need is a way to fix this problem. Thank you.

Well, as far as I know Komodo devs do not provide any deb packages for Ubuntu based distros, so I assume you have an unofficial repository in your system. I would agree with the point that update manager should safely upgrade the software, but only if the software is distributed by the official developer (which is not the case).

I’m for 4 years.

Ok, let’s try to fix your stuff.

  1. Show your Komodo version (Help - About Komodo).
  2. Show your ls -la ~/.komodoide/

Thank you. I can only re-state what I said before. I don’t see how komode-edit can possibly end up in the repositories without corroboration between komodo and ubuntu/mint. I do not have any unofficial repositories and I’ve never experienced update/upgrade problems with software packages like this before … not since my compiz days back in 2010. Well, be that as it may, the current komodo build on my setup is … Komodo Edit, version 10.0.1, build 17276, platform linux-x86_64. Built on Wed Jun 15 08:25:28 2016.

The output from (german language) the terminal is: Zugriff auf /home/winriddance/.komodoide/ nicht möglich: Datei oder Verzeichnis nicht gefunden … which means Access to blah blah blah isn’t possible because the file or folder can’t be found. Realizing my mistake since the folder should be .komodoedit …

… I then use that command for komodo edit which is what I’ve been using all along. Doing so, I receive this and nothing else:

insgesamt 24 (total of 24)
drwxrwxr-x 6 winriddance winriddance 4096 Jun 20 11:47 .
drwxrwxr-x 46 winriddance winriddance 4096 Jun 6 08:52 …
drwxr-xr-x 11 winriddance winriddance 4096 Jun 26 12:56 10.0
drwxr-xr-x 12 winriddance winriddance 4096 Mär 17 14:21 8.5
drwxr-xr-x 11 winriddance winriddance 4096 Apr 19 15:43 9.3
drwxr-xr-x 5 winriddance winriddance 4096 Mai 23 12:11 My_Komodotools_2016_Templates

The last entry from May 23rd shows my saved template configuration which was at that point still working fine. That was also the last time that I had Komodo Edit working with my colors, fonts, etc.

We’re 6 hours ahead of New York and 9 hours ahead of Seattle time. I have to leave for an appointment in about 30 minutes but should be back within 2 - 3 hours. I’ll check these messages again right before I leave.

Me too, but I can’t find Komodo Edit in Ubuntu’s repos (16.04), apt-cache search shows nothing.

First, let’s try to fix your colors problem. Open color scheme editor, apply your scheme (ensure that you’ve checked these checkboxes: )

Then, if nothing happens, share your log file (Help - troubleshooting - view log file).

Alright. I’ve tried that before but did it once again, making sure to check all of the checkboxes. Clicked on apply, then on save. Closed komodo edit and re-opened it with the launcher shortcut that still works the same as before. Did that before as well of course. The preview window for the colors does indeed show what the theme is supposed to look like. It just doesn’t apply the changes and the only thing that changes on my screen is the background color which is actually correct.
But my entire text is plain black. Here’s a screenshot too. I’m way late, have to go, be back later …

As I can see your file is not an HTML file, that’s why your text is black.
To configure interface colors, you should pick Interface in the dropdown menu
Or you can use my tool to automatically generate interface colors depending on your color scheme

Thanks for the input, but if you look at the screenshot you’ll see that HTML was already selected on the left. The file that you’re seeing in the background … the one that you’re saying is not an html file … is my html template which Komodo totally screwed up after being imported. After I was able to finally locate my templates (which were after the update no longer where they used to be) and open them up with an import/save instruction that I received on the screen from Komodo, it jumbled up all of my html templates.
That’s what my very first detailed post in this thread was about.
Now there’s “extra stuff” on top and below all of my html templates text,
as well as the additional " marks that are now all over each template page, on every line.
That’s why I thought that it might be easier for me to just revert back to Komodo Edit 9.3 or 8.5 ???


I’ll leave it to the devs, I’ve never used custom templates. I can only assume that the templates are not raw HTML files but some sort of komodo tool files.

We absolutely do not corroborate with any 3rd parties on including Komodo Edit in any Linux distribution. There are 3rd parties who in their own spare time may package Komodo Edit for their own distribution, but we are never privy to that, nor do we encourage it in any way. As Defman said, we highly recommend downloading Komodo Edit from our official website.

I would not be surprised if your distribution packaged Komodo 10.0.0, which has fixed a number of possible issues that you’re running into (like importing old themes). Did you ever get the “First Start Wizard” that allowed you to select your theme?

Any time you perform an action that does not behave as expected, please grab the contents of your error log (Help > Troubleshooting > View Log File) and post it here. Thanks!

As Mitchell said we do not collaborate with any 3rd parties for redistribution. Please uninstall your version of Komodo and install the one offered from our website. If things still don’t work we can take it from there.

Well, I obviously have no idea how I ended up with a repository version of Komodo Edit, but I still had a previously saved backup of Komodo Edit 8.5 … and also downloaded per your suggestions the versions for 9.2 and version 10 of Komodo Edit. Although I was able to install each version separately (never side by side) every one of my template files (including ones from KE 8.5) now has the same mess as with the repository installation of version 10. That one was first deleted of course, before I did any new installations. In order to fix these templates, it would take me anywhere from 1 - 2 full days, given the fact that I have to “fine tooth-comb” through each line of every file.

The only difference between the repository issues and the new installations was the fact that for version 9 the colors were my theme by default … but because of how the templates were screwed up, it was still two colors only, light background with black text.

I managed to find myself another older backup of my template files which were stored as a KPF project file from Komodo Edit version 6. However, I no longer have the installation software for version 6. Would someone please be kind enough to provide me with a link to that version (6) of Komodo Edit? (unless you think that I can import that extremely old KPF file into version 9 of Komodo Edit perhaps?) Using my older KPF would enable me to save quite a few hours of painstaking adjustments since I’d only need to do some global search/replace functions on my old templates in order to update them (again). :cry:

I have absolutely no idea what happened. About 3 weeks ago my template files were perfectly fine, and now everything is toast. Nothing on my system changed, except for the fact that I updated from the Ubuntu/Mint repository which ended up being little to no different than the new installations of Komodo Edit 9 and 10. So very very frustrating …

So you are not able to import these templates? Could you share at least one of your templates with us?

I already stated that I was indeed able to import all of the templates, but now they no longer look like the standard html file snippets that they used to be. If you look at one of the screenshots and my very first post, I already explained in detail what’s going on. Every imported template now has “gobbledigook” text at the top as well as on the bottom of each template, and there are " marks all over every template on each line of every template … also partially visible in one of my screen shots. A clean version 6 of Komodo Edit would at least enable me to import my old KPF files. From there it wouldn’t be such a big deal to re-modify my templates.

My templates used to be standard run of the mill HTML code snippets. Now every snippet is in an altered state and no longer appears to be recognized as an HTML snippet. That’s why my theme colors won’t show up either, because as explained earlier somewhere else, my templates no longer appear to be html …

Have you tried to import this “broken” template into the Toolbox? It looks very similar to a toolbox item. (that’s why there are "" things, "name": ..., etc.)

Oh man, you’re a friggen’ lifesaver !!! That was the problem. :stuck_out_tongue_winking_eye: Back in my early days of trying Komodo Edit, I contacted someone in the support area to find out how I can move the toolbox to the left side of the window. Ever since then I’ve used Komodo Edit with everything including my HTML snippets on the left side.

Well, after installing Komodo Edit several times during the past few days, everything still appeared on the left side as before … with the right pane closed as before … and it never dawned on me that it wasn’t the toolbox that I was looking at. So based on your last remark I looked at the default view options which were enabled and that’s when I noticed that I wasn’t even looking at the toolbox.

So I enabled the toolbox, closed my files, changed the pane layout to be as I had it before, and then re-located my snippets that way. Now all of them work correctly and they all show up like they’re supposed to. My custom color theme is gone completely, but that’s not a big deal at all. 5 minutes or so of fiddling and everything will be back to normal. First thing I’m going to do … just in case … is to save my 25 most important snippets as plain text files.
Thanks a million for helping me get it figured out. :grinning:

1 Like

Yaaay! Good to know that :slight_smile:

Your color scheme may not gone completely, try to find it in the profile folder of previous versions :slight_smile:

As I can see you’ve tried to open a kpf file. This should import your template in the toolbox (like when you open a ksf file, Komodo suggest you to apply this file like a color scheme instead of opening it), but it’s not.
I’ve filed a bug for it.