Watch Window - how to have it not open

New to komodo. I think I changed something unintentionally…

Am coding Pyrhon. When I run a script the Watch tab opens next to the Output tab.

Can you toggle whether the Watch window opens or not.


Hi @darienk,

Sounds like you’re looking for Run without Debugging which should be F7 (Cmd+R on OSX), or Debug menu > Run without Debugging. Sounds like you’ve started the actual debugger which is F5 (Cmd+. on OSX).

  • Carey

Thanks. I thought of that too, but even via F7 it opens. Seems like initially it was not acting this way. I may have changed some setting. I’ll keep hunting…

Hey @darienk,

My mistake, yes watch symbols is open when the debugger runs even if you “run without debugging”.

There are two other ways to run code in Komodo:

  • Run In line: Ctrl(Cmd on OSX) + B
    • Outputs to a dialog that appears ontop of the editor area
  • Toolbox Run Command
    • Outputs to the Command Output pane in the bottom Komodo

Okee dokee