Very slow Komodo IDE launches

I’ve been having unbelievably slow Komodo IDE launch speeds, so I just now removed my AppData folder, uninstalled 8.5.0, and installed 8.5.3. Initial launch was slow (GUI visible after a couple minutes, but not usable until 8-9 minutes after launch), but that might be expected with the code intelligence loading, etc. Subsequent launches are also slow, though, averaging around 3 minutes until visible, then another 20-30 seconds until it’s usable. This is with the Start Page turned off, and no files/projects loaded at launch.

HW: Lenovo X1 Carbon laptop (Core i7-3667U CPU @ 2GHz), 8GB memory
SW: Windows 8.1 Pro 64-bit

It’s not memory or CPU constrained during the launches.

Performance is “normal” on my WIndows 7 virtual desktop. Any thoughts why it’s so slow on this Windows 8 laptop, even after the fresh install?

That seems odd - as Komodo starts within 10 seconds on most systems.

  1. Does Firefox (a similar application to Komodo) take a long time to startup as well?

  2. Are you using any network drives - as that could negatively affect startup performance?

I don’t use FF anymore (switched to Chrome!), but I do have network drives, 3 of them. 2 of them were ‘offline’ since I haven’t connected to them since rebooting and re-connecting to my work’s VPN. Connecting all of them (but not using any files from them), IDE launch time is the same (3 min. til the GUI even appears).

Completely unmapping them causes the IDE to launch in 5 seconds. Nice, but I need my drives mapped. Any thoughts?

Ah, something with the mapped drive is causing this delay for Komodo. Interesting.

Does your Komodo installation, or Komodo profile (user profile) live on a shared drive? Or are you just accessing files/projects on those mounted drives?

Nothing is on those drives, in regards to Komodo or my profile or environment vars (like HOMEDRIVE, etc.). My PATH includes some folders on the network. Would Komodo be looking for something in the PATH, something optional that isn’t directly in C:\Program Files (x86)\ActiveState Komodo IDE 8?

Yes, Komodo does use the PATH environment variable - to locate executables for languages, source code control, linters, etc…

Try opening a command prompt and set the PATH to be without the network locations, then launch Komodo from within that command prompt. Any difference?

Yes, removing the network dirs from the PATH gives a nice 5-sec. launch! I can write a BAT script to launch Komodo with a simpler path, but if you think this is something that can/should be fixed, please consider doing so! Must be others who run into this too…

A fix would be nice - but I don’t think it’s possible.

I did notice a few cases where we were checking too much (and have since reduced those checks to a 1/3 of what they were), but Komodo needs to know if certain executables exist - in order to enable certain functionality, so we cannot simply remove all of those checks.

BTW - added a Komodo bug and known issue here:

You could also edit Komodo’s PATH environment variable inside the Komodo Environment preferences panel - that should do a similar thing to the wrapper and make it a littler more convenient.


I have Win 7 and my desktop also takes too long to appear after local machine logging in. This is all due to the network mapping and the way network communication only occurs well after login so the mapped drives are not ready. Removing the local dependency upon a DNS server and using raw I.P. addresses may help but in reality I suffer none of this if I use my Mac or use my Linux machine.

If your desktop work machine is set to automatically start Komodo then simply remove the program from your start-up menu then allow your M$ work machine to ‘settle down’ before you load Komodo.

I would also like to see an answer to this (from M$) but this is unlikely. A cludge fix might be to delay network mappings. Another alternative is to use CVS and completely work locally - or switch to using a Mac on your network shared drives :smile: