Version 12, failed to set up the debugger


#1

“komodo failed to set up the debugger for language python3”
12.0.0 Safe mode fails as well
I emailed the log file, Carey has it.

Lou


#2

K just confirmed it’s working for me, so let’s figure out what’s goin on for you!

When you reset the profile, did you confirm that you get the same error in the logs?

How did you install Komodo? Did you happen to use sudo? If you did that tends to bung up Komodo and break many things. sudo chwon -R lou:lou /path/to/komodo should resolve that and removing whatever profile was created last time you ran Komodo which can be found at ~/.komodoide/.

  • Carey

#3

No, installed as user, all are lou:lou. lou@mint191:~$ ls -al Komodo-IDE-12/
total 20
drwxrwxr-x 5 lou lou 4096 Jan 1 12:19 .
drwxr-xr-x 30 lou lou 4096 Jan 2 17:34 …
drwxr-xr-x 2 lou lou 4096 Jan 1 12:19 bin
drwxr-xr-x 6 lou lou 4096 Dec 17 19:38 lib
drwxr-xr-x 3 lou lou 4096 Dec 17 19:38 share

This was initial install, no previous version of Komodo IDE on this Mint 19.3 Virtual Machine. I did try a reset all and that did nothing but make me play phone home again. I took all the defaults on the start up after reset. The log looked pretty much the same, didn’t compare line by line.
If you are busy with important stuff, I don’t really need to pursue it now that I have 11 working on my host.

Lou


#4

Morning @louyov,

Thanks for that. This is pretty important. If debugging is broken in the new release in certain cases I’d like to figure out why. If YOU have time then I’m appreciative of any assistance.

I looked at your logs again and noticed something I should have seen before. It looks like something Komodo relies on to setup the debugging session is missing. Could you try opening your terminal and installing xterm?
apt-get install xterm

Then restart Komodo and try debugging again.

Do you also have Komodo 11 installed on the same machine? If the above is what’s wrong then 11 should be broken too…

  • Carey

#5

Relevant log output:

ERROR:xpcom:Creation of class '<class 'component:koInvokeInterpreters.koPython3Invocation'>' failed!
Exception details follow

ERROR:xpcom:Unhandled exception calling 'int8 * createInstance(in nsISomething, in nsIID &, out retval InterfaceIs *);'
Traceback (most recent call last):
  File "[redacted by Carey]/Komodo-IDE-12/lib/mozilla/python/xpcom/server/policy.py", line 303, in _CallMethod_
    return 0, func(*params)
  File "[redacted by Carey]/Komodo-IDE-12/lib/mozilla/python/xpcom/server/factory.py", line 57, in createInstance
    return self.klass()
  File "[redacted by Carey]/Komodo-IDE-12/lib/mozilla/components/koInvokeInterpreters.py", line 1081, in __init__
    koPythonCommonInvocation.__init__(self)
  File "[redacted by Carey]/Komodo-IDE-12/lib/mozilla/components/koInvokeInterpreters.py", line 771, in __init__
    koInterpreterInvocation.__init__(self)
  File "[redacted by Carey]/Komodo-IDE-12/lib/mozilla/components/koInvokeInterpreters.py", line 265, in __init__
    raise Exception(msg)
Exception: No supported terminal was found, please install xterm
  • Carey

#6

sudo apt install xterm fixed it.
No, version 11 was not installed.
Thanks
Lou


#7

@louyov,

Thanks a lot for confirm.

If anyone comes across this thread with the same issue, please comment. So far I know of 3 test cases that are not able to reproduce this. I want to know if this is wide spread. In the mean time I’ll treat it as an isolated incident and Lou, as stated above, just being Jinxed :stuck_out_tongue:

  • Carey