Unwanted autocomplete


#1

I get some unwanted autocomplete with Komodo IDE 11.0.1

For example :

body{}  

The closing curly brace is added automatically (that’s ok). So the cursor is inside the curly braces.
If I hit enter, I get this :

body{-moz-appearance: }

So I have to hit escape before hitting enter, to get this :

        html, body{
            
        }

Here’s another example in combination with emmet :

“m” is the abbreviation for “margin”. If I hit “m”, then tab to expand the abbreviation, I get this :

margin: marks: ;

There’s plenty of other examples. Is it this a known bug ?


#2

Oh, just found that :

Bug in 11.0.1


#3

Right. 11.0.2 has been released, so you may try upgrading to that.


#4

Excellent !!! Issue solved. Thanks


#5

My bad.

This issue is NOT solved in 11.0.2. I just add “Enable completions” unchecked !

When checked I get this for instance :

In css :

I press m, then hit tab, and I get this :

margin: marks: ;

tab is used for xemmet, so it should do auto-complete in this case.

I open a separate case