Unreadable tooltips

I have just downloaded Komodo 9.0.1 and am delighted with it. Except that, if I’ve left out a /div somewhere in a large file there’s a squiggly line under /body and /html and, unfortunately, when I mouseover them the tooltip is around 5px high and therefore unreadable which is hugely frustrating. I hunted everywhere for a solution but couldn’t find one.

Could you provide a sample snippet and a screenshot? So we can see the exact problem and attempt to reproduce it.

Also - what OS are you using, and are you using Edit or IDE?



Can you repro this using a default color scheme?

What is your OS DPI setting (are you using a HiDPI screen)?

I’m using a Dell E228WFP monitor, 1680 x 1050. Definitely not HiDPI!
I’ve attached 2 screenshots, using 2 different default color schemes, and also turning off Wordwrap in one of them. I had cleared all the code Intelligence checkboxes, but nothing changed when I checked them all.
Having created the attached file using an ancient and horrible copy of ExpressionWeb (but edited in Komodo) I also created a new page in Komodo and nothing changed. I closed all the programs that were running, except Firefox, but nothing changed.
Having written the above, I uninstalled KomodoIDE, downloaded it again. (Komodo Edit, version 9.0.1, build 15745, platform win32-x86. Built on Fri Apr 24 10:22:17 2015) and still nothing changed!

Could you see if the problem also happens on Komodo IDE? (just install the trial).

Good job I just upgraded my broadband allowance! Different website, different file, different drive. It’s still the same.

I notice you’re using some type of custom windows skin, is it possible to disable that to see if it has any effect?

That got it!! Damn. I liked that skin. Congratulations on your problem-solving skills.

Glad that sorted it :slight_smile:

I still have this problem in Windows 8. Unfortunately I cannot disable my theme as it is part of windows itself. I suspect this will render the same result in Windows 10.

UPDATE: Problem still exists in Windows 10.

Are you using a non-default DPI setting? I’m not sure what Windows would call this, text scaling perhaps?

I think it’s this: http://www.sevenforums.com/tutorials/443-dpi-display-size-settings-change.html

I do have a high display screen, but I’m not going to disable it since I need it for other programs to look correctly (especially as a programmer). Is there a way to disable it in just KOMODO without affecting my other applications?

UPDATE: I can view the “linter error indicators” fine, but for some reason the “linter warning indicators” do not show correctly. I wander what it different there in the source code (just a thought).


Unfortunately you cannot disable HiDPI for specific apps, that would be like having a different resolution for different apps.

Could you report a bug for your issue? Please include your specifications (OS, monitor, resolution, any non-default OS settings that may relate to DPI).