Unity menubar overwrite error

I just upgraded to Komodo 10.1.0 and tried to apply the instructions for Unity menubar in Ubuntu (see https://github.com/garak/Komodo-IDE-Ubuntu-global-menu)

Unfortunately, I’m getting the following error in the left tab:

XML Parsing Error: undefined entity
Location: chrome://komodo-places/content/places_panel.xul
Line Number 372, Column 7:

The top menu is fine and it’s displayed on the Ubuntu bar (where it’s supposed to be), but the left pane is gone.

Following attached log:

[2016-08-29 11:27:58,322] [INFO] Startup: Welcome to Komodo IDE 10.1.0 build 89455 (platform linux-x86_64, running on Linux 4.4.0-34-generic version #53-Ubuntu SMP Wed Jul 27 16:06:39 UTC 2016)
[2016-08-29 11:27:58,322] [INFO] Startup: /usr/bin/python built on Mon Aug 22 08:51:14 2016
[2016-08-29 11:27:58,409] [INFO] koInitService: Setting LC_CTYPE to utf-8
[2016-08-29 11:27:58,712] [WARNING] console-logger: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create (1) in resource://gre/modules/Preferences.jsm:381
[2016-08-29 11:27:58,829] [WARNING] console-logger: Expected identifier for pseudo-class or pseudo-element but found ' '.  Ruleset ignored due to bad selector. (1) in chrome://komodo/skin/codeintel.css:1
[2016-08-29 11:27:58,829] [WARNING] console-logger: Unexpected end of file while searching for closing } of invalid rule set. (1) in chrome://komodo/skin/codeintel.css:42
[2016-08-29 11:27:58,869] [WARNING] root: ko.logging has been converted to a CommonJS module; use require("ko/logging") instead (since Komodo 9.0.0a1).

[2016-08-29 11:27:59,083] [WARNING] console-logger: Failed to load overlay from chrome://komodo/content/formatters/formatters-overlay.xul. (1) in chrome://komodo/content/komodo.xul:0
[2016-08-29 11:27:59,596] [WARNING] keybindings: [Ctrl+0] was used for 'cmd_goToQuickBookmark_0', overriding to use 'cmd_fontZoomReset'
[2016-08-29 11:27:59,995] [INFO] koInitService: Adding pre startup service for 'koFileStatusService': '@activestate.com/koFileStatusService;1'
[2016-08-29 11:28:00,140] [INFO] komodospellchecker: Spell checker loaded.
[2016-08-29 11:28:00,140] [INFO] komodospellchecker: Using dictionary en-US
[2016-08-29 11:28:00,239] [ERROR] koScopeDocs-Py: Could not find cix for ext
[2016-08-29 11:28:00,281] [ERROR] koScopeDocs-Py: Could not find cix for html5
[2016-08-29 11:28:00,486] [ERROR] console-logger: TypeError: document.getElementById(...) is null (2) in chrome://analytics/content/analytics.js:137
Traceback (most recent call last):
  File "chrome://analytics/content/analytics.js", line 137, in 

[2016-08-29 11:28:00,527] [ERROR] console-logger: uncaught exception: [object Object] (0) in :0
Traceback (most recent call last):
  File "", line 0, in 

[2016-08-29 11:28:00,570] [WARNING] console-logger: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create (1) in file:///opt/komodoide10/lib/mozilla/components/koamAddonManager.js:138
[2016-08-29 11:28:00,647] [ERROR] console-logger: undefined entity (0) in chrome://komodo-places/content/places_panel.xul:372
Traceback (most recent call last):
  File "chrome://komodo-places/content/places_panel.xul", line 372, in 

[2016-08-29 11:28:01,458] [WARNING] commands: updateCommandset: cmdset_history
[2016-08-29 11:28:01,460] [WARNING] commands: updateCommandset: komodoFileSaveItems
[2016-08-29 11:28:01,461] [WARNING] commands: updateCommandset: cmdset_for_showHideMinimap
[2016-08-29 11:28:01,461] [WARNING] commands: updateCommandset: cmdset_cutcopydelete
[2016-08-29 11:28:01,463] [WARNING] commands: updateCommandset: cmdset_selection
[2016-08-29 11:28:01,465] [WARNING] commands: updateCommandset: cmdset_view_codeintel_changed
[2016-08-29 11:28:01,466] [WARNING] commands: updateCommandset: cmdset_view_or_language_changed
[2016-08-29 11:28:01,467] [WARNING] commands: updateCommandset: cmdset_currentview_is_editor_on_html
[2016-08-29 11:28:01,467] [WARNING] commands: updateCommandset: cmdset_view_dependent
[2016-08-29 11:28:01,469] [WARNING] commands: updateCommandset: cmdset_undo
[2016-08-29 11:28:01,470] [WARNING] commands: updateCommandset: cmdset_place_bufferOperations
[2016-08-29 11:28:01,470] [WARNING] commands: updateCommandset: cmdset_place_treeOperations
[2016-08-29 11:28:01,471] [WARNING] commands: updateCommandset: cmdset_markdown_previewability_changed
[2016-08-29 11:28:01,471] [WARNING] commands: updateCommandset: publishing_commandset
[2016-08-29 11:28:01,474] [WARNING] commands: updateCommandset: cmdset_some_files_open
[2016-08-29 11:28:01,475] [WARNING] commands: updateCommandset: cmdset_refactoring
[2016-08-29 11:28:01,476] [WARNING] commands: updateCommandset: cmdset_clipboard
[2016-08-29 11:28:01,479] [WARNING] commands: updateCommandset: cmdset_place_contextMenu
[2016-08-29 11:28:01,902] [WARNING] console-logger: Error in parsing value for 'opacity'.  Declaration dropped. (1) in chrome://komodo/skin/images/toolbox/command.svg:0
[2016-08-29 11:28:02,007] [WARNING] commands: updateCommandset: cmdset_undo
[2016-08-29 11:28:02,073] [WARNING] commands: updateCommandset: cmdset_view_codeintel_changed
[2016-08-29 11:28:02,881] [INFO] koInitService: Adding pre startup service for 'KoMemoryReporter': '@activestate.com/koMemoryReporter;1'
[2016-08-29 11:28:02,882] [INFO] koInitService: Adding pre startup service for 'koCommandmentService': '@activestate.com/koCommandmentService;1'
[2016-08-29 11:28:02,886] [INFO] koInitService: Adding pre startup service for 'koDBGPManager': '@activestate.com/koDBGPManager;1'
[2016-08-29 11:28:03,242] [WARNING] commands: updateCommandset: cmdset_place_main
[2016-08-29 11:28:03,251] [WARNING] commands: updateCommandset: cmdset_openfiles
[2016-08-29 11:28:04,657] [WARNING] commands: updateCommandset: cmdset_undo
[2016-08-29 11:28:04,833] [WARNING] commands: updateCommandset: cmdset_undo
[2016-08-29 11:28:12,101] [ERROR] workspace: waitForProjectManager: Gave up trying to restore the projects workspace
Traceback from ERROR in 'workspace' logger:

[2016-08-29 11:28:52,236] [WARNING] console-logger: Key event not available on some keyboard layouts: key="v" modifiers="control,alt" (1) in chrome://komodo/content/tail/tail.xul:0
[2016-08-29 11:28:52,454] [WARNING] commands: updateCommandset: cmdset_selection
[2016-08-29 11:28:52,468] [WARNING] commands: updateCommandset: cmdset_clipboard
[2016-08-29 11:28:54,451] [WARNING] commands: updateCommandset: cmdset_cutcopydelete
[2016-08-29 11:28:54,455] [WARNING] commands: updateCommandset: cmdset_view_dependent
[2016-08-29 11:28:55,508] [WARNING] commands: updateCommandset: cmdset_selection
[2016-08-29 11:28:55,520] [WARNING] commands: updateCommandset: cmdset_clipboard
[2016-08-29 11:29:13,921] [WARNING] commands: updateCommandset: cmdset_cutcopydelete
[2016-08-29 11:29:13,930] [WARNING] commands: updateCommandset: cmdset_view_dependent
[2016-08-29 11:29:15,061] [WARNING] commands: updateCommandset: cmdset_selection
[2016-08-29 11:29:15,072] [WARNING] commands: updateCommandset: cmdset_clipboard
[2016-08-29 11:29:15,865] [WARNING] commands: updateCommandset: cmdset_cutcopydelete
[2016-08-29 11:29:15,877] [WARNING] commands: updateCommandset: cmdset_view_dependent
[2016-08-29 11:29:16,819] [WARNING] commands: updateCommandset: cmdset_selection
[2016-08-29 11:29:16,823] [WARNING] commands: updateCommandset: cmdset_clipboard

Update: tried to re-install Komodo 10.0 and I’m getting the same error by applying the code from @Mystic_Mirage
Using the PPA code for Komodo 9.3 was working fine, so I assume that something changed in the PPA. Unfortunately, the old PPA packages were removed :frowning:

Some old packages can be found here – https://launchpad.net/komodo-edit/+download

Thank you @Mystic_Mirage but it looks like there’s only deb files. I need tar.gz files for 9.3
Anyway, any thoughts about Komodo 10 working with old 9.3 unitymenubar files and not working with 10.0?

Thanks again

I have no idea. Never tried to use Unity patched files with Komodo IDE.

Is it possible to get somewhere unitymenubar in tar.gz format? I tried to extract files from the deb, but no luck


Are you looking for that kind of archives?

Try to overwrite only these files
./mozilla/chrome/toolkit/content/global/xul.css ./mozilla/chrome/toolkit/content/global/bindings/popup.xml ./mozilla/greprefs.js ./mozilla/libxul.so

1 Like

Yes that ones. Is there a list of them somewhere? I need the one for 9.3
I know which files to overwrite, trying with the ones extracted from .deb file didn’t work (komodo just hanged with many errors and didn’t start)

As I can remember there are no differences between patched files for 9.0 and 9.3

It’s working! Thanks a lot.

1 Like

@garakkio mind sharing your solution here for the benefit of others that may be wondering the same thing? :slight_smile:

Yes, please. I’d want to add global menu support until the corresponding pull request is merged.

I just did the same I always do, like explained in https://github.com/garak/Komodo-IDE-Ubuntu-global-menu
The only thing to mention is that using the latest version of Mystic Mirage PPA (for Komodo 10) is not working, so I had to use the Komodo 9 version.
Anyway, applying the files for Komodo 9 to Komodo 10 (and Komodo 10.1) is working fine

I got it working with the archive for Komodo 10, but I replaced only files that @Mystic_Mirage listed in its post.