Unindent menu option rename

“Dedent” is not a word. “Unindent” is.

The menu option should be renamed.

Btw I’ve googled a bit. There are at least 3 forms of this word: dedent, unindent, outdent. And the library Komodo uses for operating with indentation provides dedent method, that’s why there’s “Dedent” and not “Unindent”.

I got Google too! :wink:

My feeling is that dedent goes with dent and undent, as in fixing a car after an accident. Cf: debug, delouse.

An outdent is a dent from the inside out. You fix it by undenting, similar to undenting a dent from the outside in. What remains is an undented whatever.

Furthermore it seems to be used mainly in the Python world.

My guess is that, if you put it to the vote, unindent would win by a fair margin.