Unable to use Python 3 syntax on remote server

I can’t seem to figure out how to use Python 3 Syntax when I open a file on a remote server. I am using the ‘async’ and ‘await’ keywords in my python files, which were introduced in Python 3.5 I believe.

In my preferences, I have changed the File Association for *.py files to be Python 3. This seems to work fine when I open local py files. I open my file, and the async and await keywords are colored as expected and Komodo doesn’t complain. However, when I open the same exact file on a remote server, async and await are not colored and a red line appears under my ‘async def’ line complaining I have a syntax error.

When I go to ‘Current File Preferences’ > ‘Syntax Checking’ the dropdown box only gives me the option of Python and not Python 3. I tried creating a project and changing the project preference to Python 3 as well with no luck. I added “#!/usr/bin/env python3” to the top of the file and a number of other things.

Does anyone have any idea what I’m doing wrong? I have Python 3.6 installed on the remote server and the result of ‘which python’ is the same on both my local and remote machines.

Build Info:
Komodo Edit, version 10.2.3, build 17708, platform linux-x86_64

Ubuntu 16.10

Hey @jrbennyboy11,

Did you try just setting the language to Python 3 in the status bar for the file?

  • Carey

I did not! That did the trick. Thank you so much!

1 Like