Unable to exclude subdirectories from find in files

I have been unable to successfully exclude “find in files” searches from subdirectories in my working directory.
I’m hoping someone will be able to point out a solution.

Version: Komodo IDE, version 9.3.1, build 88153, platform linux-x86_64 Built on Tue Nov 17 11:11:42 2015.

Find: Tests Not Run
Where: Files
Directories: /nfs/newadmin/public/users/crs/testbuddy
Include: .p?
Exclude: /nfs/newadmin/public/users/crs/testbuddy/
…lic/users/crs/testbuddy/savex86/TestAPI.pm 362 report “Tests Not Run;\n”;
…lic/users/crs/testbuddy/savex53/TestAPI.pm 213 report “Tests Not Run;\n”;
…lic/users/crs/testbuddy/savex62/TestAPI.pm 213 report “Tests Not Run;\n”;

Exclude only works on file/folder names at the moment, you cannot exclude complete paths (yet).

Thanks for the suggestion but I can’t even exclude subdirectories such as “savex86” by including Exclude: savex86:.syn:CVS…
I have a lot of “savexNN” sub directories which unfortunately have matches for most strings.

That’s odd, that should definitely work. Could you share your complete exclude string?

The split symbol is ; (not :)

Full exclude string pasted:

Actually : is correct.

Could you see if putting savex86 at the end instead of the start makes a difference? Perhaps even try ONLY entering savex86.

1 Like


Ahh sorry for confusing, there’s a difference between new Search pane and Settings. Didn’t know about that.