Ubuntu global menu

About the Ubuntu global menu (aka Unity menubar), I tried with success what suggested on old forums, on a 64bit computer.
But same solution had no effect on another computer, 32bit.
Both computers run Komodo IDE 8.5

The solution

Please note that the PPA you are referring to is not managed by us, it is generously maintained by “Mystic-Mirage”. Your best bet would be to get in contact with him.

As a temporary workaround you can use the built-in menu button in Komodo by right clicking your menu or toolbar area and toggling “Show Menubar”.

Thank you @nathanr for your reply.
I resolved my issue by copying files from single dirs in the zip mentioned above (noarch and x86 dirs). I forgot procedure since last time I followed it.

Anyway, I think that Komodo should support mistyc mirage extension, since desktop integration is IMHO one of strong points of Komodo edit/ide. I mean, you should at least link the extensione somewhere from official komodo website. BTW, screenshot provided on http://komodoide.com/ shows Ubuntu version without ugly inline menu :wink:

Glad you got it sorted. We’ll look into supporting the global menu natively in future releases.

Note that the extension was originally developed by Chris Coulson and integrated into Komodo by @toddw, it has since been added to the PPA repository by Mystic-Mirage. I don’t know whether Mystic has made any modifications, just giving credit where credit is due.

2 Likes

I think on screen disabled “View -> Toolbars -> Show menubar”. And globalmenu doesn’t work correctly, because it loading menu from Komodo window and if you unchecked “Show menubar” - global menu just removed.
But if you want global menu, you get this trouble: (2 menus, yeah).

How i install global menu:
Download this:
https://launchpadlibrarian.net/159511579/komodo-unity-menubar.zip
Unpack content of folder (“moziila” folder) “x86_64” or “x86” to {Komodo_install_folder}/lib
Restart Komodo Edit if it run.
Done!
PS: Oh, sorry, i didn’t see your post, where you do this :slight_smile:

Well, today I installed 8.5.4 (since update from 8.5.3 was not working) and I am again with the ugly menu :frowning:
I tried to search inside new 8.5.4 deb package from mystic myrage, but it looks that it’s not exactly like the old tar.gz provided (in old forums) with just libs for global menu.
It is any chance to get a version of that .tar.gz for 8.5.4?
Meanwhile, I solved by looking into old .tar.gz, downloading new .deb and extracting single files. But this is not really a simple procedure…
TIA

Global Menu is not currently maintained or supported by us, far as I can tell anyone is free to fork that project though.

Note you could use the Unified menu in Komodo by right clicking the toolbar and selecting “Show Menubar”, this will place the menu items in a toolbar button at the right side of your toolbar. Unfortunately the toggle itself is slightly bugged in Komodo 8.5.4 atm and you should restart Komodo after toggling. This will likely be fixed in a nightly and is already fixed in the Komodo 9 pre-release.

Well, Komodo 9 is out and everything is starting over :disappointed_relieved:
I tried the solution proposed by @Defman, downloading komodo-unity-menubar.zip and replacing files by hand, but I’m getting the following error

XPCOMGlueLoad error for file /opt/komodoide9/lib/mozilla/libpyxpcom.so:
/opt/komodoide9/lib/mozilla/libxul.so: version `xul35’ not found (required by /opt/komodoide9/lib/mozilla/libpyxpcom.so)
Couldn’t load XPCOM.

I guess it depends on different versions of xul libraries.
Is there any hope to get global menu working on Komodo 9? My current Ubuntu version is 14.04.

Create an enhancement.

OK, I managed to get it working, so I’m sharing my experience here (since this topic is among google results).
I downloaded komodo-edit_9.0.0+15707~unitymenubar2.tar.gz from launchpad, I opened it with file-roller and I extracted the folder named “unity-menubar”. Then I copied file from “noarch” dir to [komododir]/lib/mozilla and I copied files from “x86_64” dir again to [komododir]/lib/mozilla (note: if your system is 32bit, you need to copy files from “x86”, not from “x86_64”).
That’s it! :smile:
Thanks anyway for your help.

Glad you got it sorted. But I still think it’s better to create an enhancement.

That’s great! Consider sharing it on the Resources section? :slight_smile:

@Defman as you can see in this very thread, a Komodo developer already told me that global menu is not officially supported.
@nathanr I’m not familiar with Resource section, but if you tell me more I’ll be glad to help anyone else in my same situation.

Instructions are in the sidebar, direct linky: http://komodoide.com/resources/submit-instructions/#pane-resources

Thanks! :slight_smile: