Toolbar buttons blank after upgrade

I just got the recent upgrade:
Komodo IDE, version 8.5.4, build 86985, platform macosx

All the icons in the toolbar immediately disappeared:

I’m using “IconSet Classic 1.0” and “Skin: Default”. The scheme is also “Default”. I’ve tried switching all three to alternatives and back, but the icons never reappear. Not sure how to proceed from here.

I just blew away both user directories:

rm -rf /Users/fraser/Library/Application\ Support\Komodo*IDE

This took nearly 30 seconds (what the heck was in there?) and now Komodo’s icons work again.

Problem solved. Sort of.

Hey Neil,

Here’s an explanation of what’s in the Komodo user profile folder.

For future reference you could probably just remove the XRE folder rather than the whole folder.

It is unfortunate you had to do that at all though. Nathanr did a massive overhaul of the Komodo UI and there are occasionally issues but he’s fixed many of them. I hope this wasn’t too much of a pain for you to workaround and get back to work.

  • Carey
1 Like