Templates not working

Language templates seem to be broken in my install. When I select new and one of the templates, nothing happens. When I select new > file from template… no templates are shown. How to fix?

It’s working fine for me. We need more details.
Anything in your logs? Help > Troubleshooting > View Log File
What version of Komodo? Exact build number, Help (Komodo on OSX) > About Komodo
What platform?

Komodo IDE, version 11.0.0, build 90668, platform win32-x86.
Built on Tue Sep 19 14:50:13 2017. On Windows 10.

This interface won’t allow me to upload log files, only images. Odd for a support board. pystderr.log is here, and pystdout.log is here.

Knowing about these files, I tried new > perl.pl template before sending this. It didn’t seem to add anything to either file.

It also might be relevant that I recently installed v 11 over v. 8.

Thanks for confirming all that. This issue should be resolve in the latest nightly build and will be released in 11.0.1 soon:

You’ll want to have Komodo reimport your Komodo 8 profile so go to C:\Users\YOU\AppData\Local\ActiveState\KomodoIDE and rename the 11.0 folder before you start the nightly.

When 11.0.1 is released you will be prompted to auto-update to that release.

Of course, if the above doesn’t resolve your issue, let us know.

So I installed the 11.0.1 update but forgot your instruction about renaming the 11.0 folder, and now I don’t even get a list of templates when I select new. My bad. But how to fix now that the new version is installed?

You still have to follow those steps I mentioned before.

OK. I did this. Now, no languages are shown on the New menu, and New > File from template shows no templates.

Also doing this erased preferences I set up. Is there any way to restore these from the renamed 11.0 file?

@DryHeat122, before we do anything more, could you please try restarting in Safe Mode and make sure you are shown templates? Help > Troubleshooting > Restart in Safe Mode

Yes, when I restart in safe mode the templates are there.

Hi @DryHeat122,

Thanks for your patience.

Following the steps i provided should not delete all your prefs but it does remove some of them. Some cannot be imported across major versions updates. You’ll have to clarify which ones didn’t work. Usually the UI related prefs are not imported.

To get you up and running I would suggest start a fresh profile then importing what you need from the Komodo 8 profile.

  • Help > Troubleshooting > Reset Everything
  • Then manually import your tools and XRE/Addons folder from your Komodo 8 Profile.

Did you have custom File Templates as well?

No, no custom templates. So reset everything didn’t change anything. So I uninstalled 11.0 and 11.1 and 8.5, then reinstalled 11.1, and the templates are there now. Thanks for your help.

Did you follow the instructions on resetting the profile? It should have reset Komodo to a new install state. Reinstalling Komodo doesn’t do anything to your profile.

I uninstalled everything, hid the config folders, and reinstalled, and now it’s working properly. Thanks for your help.