Tab indentation always overriden

Even if “Allow file contents to override Tab and Indentation settings” is unchecked, everytime I create a newfile, I have to go to file preferences and set tab spaces back to 4.

In my general indentation settings, it’s 4 “spaces per indent” (for Global Indentation Settings, and for all file types).

“Prefer Tab Characters over spaces” is unchecked.

I’m on 11.1.0 (windows 10).

EDIT : this happens just in one folder ! And that folder was created with “vue init webpack foldername” …


It turns out to be the presence of that file in the folder :


It had the parameter “indent_size = 2”