Syntax checking settings problem

There seems to be a problem with Komodo syntax checking settings. The changes in the settings dialog are not applied immediately. There is the dialog on Edit >> Preferences >> Syntax Checking path. The checking/unchecking of the first checkbox in the right pane (Enable background checking after __ msecs, let’s call it CHECKBOX for the rest of the topic :slight_smile: ) is not applied immediately, the file needs to be reopened (or Komodo to be restarted), after that the changes are applied.

Even more precisely: If user unchecks the CHECKBOX, Komodo stops to check the syntax automatically and the syntax-checking can be invoked manually by clicking the Refresh button in the Syntax Checking Status tab in bottom pane of the editor (let’s call it REFRESH for the rest of the topic :slight_smile: ). So far so good. If Komodo starts with the CHECKBOX unchecked, the syntax checking can not be invoked by hitting REFRESH. Furthermore, if user changes settings and checks the CHECKBOX, syntax checking still does not start, even if the REFRESH has been clicked. The file simply needs to be re-opened or Komodo restarted to start the syntax checking.

Sorry for the tl;dr post, however, I took time to exactly check the behavior to get the most precise description.

I am not whether this issue should go to the bug tracker.

It should. The “issue” can be a problem or an enhancement

Hi @don,

Needing to reopen a file to inherit new global preference settings is expected behavior.
I’m not sure I fully follow the second paragraph but it sounds like the first. Global prefs don’t effect currently open files when changed. I’m not seeing the behavior you mention where no syntax checking occurs even if I re-enable syntax checking on a file, though I do have to close and reopening, which again, is expected.

  • Carey

@careyh thanks again for the reply. I will try to describe the inconsistent behaviour more precisely on two concrete cases. I am not native English speaker so it might be somewhat confusing, but please bear with me :slight_smile:

  1. Currently it does affect currently open files. But only if background syntax checking was enabled when Komodo has been started or file has been opened. After that, when the background syntax checking gets disabled in Preferences, the changes are applied immediately and the background syntax checking stops. Syntax checking can be invoked on-demand by clicking the REFRESH button (see first post for the REFRESH meaning in this case).

  2. Background syntax checking was disabled when Komodo has been started or file has been opened. On-demand syntax checking can not be invoked by clicking the REFRESH button. When the background syntax checking gets enabled in Preferences, the changes are not applied immediately and the file needs to be reopened or Komodo restarted.

It seems the RERFESH button in the Bottom Pane (in the Syntax Checking Tab) completely depends on the background syntax checking status as described above. I would like to use Komodo with background syntax checking disabled and perform syntax checking on-demand by clicking that button.

Ok, you can [file an enhancement request][1] that you would like the on-demand syntax checking even when syntax checking is turn off