[Solved] No scrollbar on my mac - hard to move around in large documents

Hi everyone, I’m using Komodo edit 10,2,0 build 17657 on Mac OS 10.12.5
I am working on large documents (dictionary text files) and I really like to use Komodo, but there is no scroll bar on my Mac. This make it really hard to browse these large documents.

I have tried all the 3 different scroll bar options in the Mac OS system settings but I cannot get the scroll bars to show.

I’m sure this is just something I’m missing.

Anyone can help me scroll around my documents?


Can you install 10.2.2 and see if the issue continues? You shouldn’t need to do anything special to get a scrollbar in Komodo.

  • Carey

In addition to what carey said please see if you can reproduce this with the default color scheme.

Hi and thanks for helping. I installed the version 10.2.2 and I switched to the default colour scheme but I still lack a scroll bar both vertically and horizontally, but with the default colour scheme I noticed there is a space for the horizontal scroll bar which I didn’t see with my other color scheme,

Does Help > Troubleshooting > Restart in Safe-Mode resolve the issue?

Yes, I have scollbars in safe mode! So nice to have them !

@msgeek, as soon as you restart Komodo the scrollbar might disappear again. Safe-Mode (like life) is only temporary (#deepthoughts).

@nathanr, didn’t we have a preference at somepoint that disabled scrollbars on OSX?

  • Carey

As Carey said safe-mode is only temporary, it’s a way to test if the problem is in your profile.

Try restarting Komodo again, then open the bottom panel and go to the Console tab. Once there, execute the following code:


Then restart Komodo again.

@careyh good thinking!

1 Like

Wow thanks a lot that line of code in console fixed the issue.

Have a great day!

I had the same problem, and this solution fixed it, thanks!

I’m new to this forum: can you mark this thread as Resolved? I almost overlooked this because I thought there was no solution attached.

@hommealone, I thought we just had to mark one of the answers a “the solution” and the forum would work some magic but i’ve changed the title to append [Solved] to it and moved it to Support Resolved section of the forum. Thanks for the head up.