Shrinking Indentation Problem


Why does Komodo Edit shrinks the indentation very often? This mostly happens on JavaScript files. Is there a solution to fix this? Or is it intentional to make the indentation shrinked?


Shrinking? Did you mean an indentation is smaller than indentation in another type of files (e.g. PHP)? You can set your own indentation in Prefs - Editor - Indentation - Per-Language Indentation Settings.

Per-Language Indentation Settings are disabled by default, you wouldn’t want to be looking at those unless you actually changed those in the past.

More like you’ll want to consider disabling Allow file contents to override Tab and Indentation settings globally or for your project if you feel Komodo is not getting the right indentation type often.

This is likely an indicator that your files are using mixed indentation though, which could screw up Komodo’s indentation detection.