Scrolling problems with Komodo Edit

On my new laptob ( Win8, Samsung, Elan Touchpad) i hab ethe follow problem:

  • i cant scroll vertically in editor
  • it does scroll vertically if I use the zoom gesture

The horizontally scrolling works fine

Some suggestions?

How are you performing the vertical scroll? (mouse, trackpad, etc)

Oh, sorry. I forgot to mention.

If I use my Logitech Mouse, scrolling works like a charm (mousewheel)

but if I use my touchpad, I got the described problem …

Seems your touchpad might not be sending the right signals, though I’m not familiar enough with the scrolling code to know whether that is an issue on our side or that of the trackpad. @toddw can you weigh in?

@2011pbosi could you ensure that you have the latest drivers installed for your trackpad?

in other apps your touchpad scroll normal?

Also, try using the latest Komodo nightly from here:

to see if that makes a difference.

Latest drivers are installed and the touchpad works fine in other apps.
I tried the nightly version, but this doesnt changed anything.

Before installation my version was 8.5.3, now 8.5.4 nightly

If I disable “Use the Minimap Scrollbar” in Edit->Preferences->Editor, everything works

Thanks @2011pbosi, knowing it’s related to the minimap will make this a lot easier to fix. For now I’d suggest leaving the minimap disabled, we’ll try to fix this issue in a nightly if possible.