Ruby debugging with Komodo IDE 11.1 for Mac


#1

Hi

I’m trying to use the Komodo IDE 11.1 (Mac) debugger to debug a Ruby script. The first time I tried I received the message saying that I needed to gem install byebug.

This I did, but now when I try to run the debugger I get the error:

wrong number of arguments (given 2, expected 1)
/Applications/Komodo IDE 11.app/Contents/SharedSupport/dbgp/rubylib/rdbgp2.rb:562:in `initialize'
/Library/Ruby/Gems/2.3.0/gems/byebug-10.0.2/lib/byebug/context.rb:145:in `new'
/Library/Ruby/Gems/2.3.0/gems/byebug-10.0.2/lib/byebug/context.rb:145:in `processor'
/Library/Ruby/Gems/2.3.0/gems/byebug-10.0.2/lib/byebug/context.rb:98:in `at_line'
/Users/pemcg/git/cfme-log-parsing/ems_refresh_timings.rb:1:in `<top (required)>'
/Applications/Komodo IDE 11.app/Contents/SharedSupport/dbgp/rubylib/rdbgp2.rb:423:in `debug_load'
/Applications/Komodo IDE 11.app/Contents/SharedSupport/dbgp/rubylib/rdbgp2.rb:423:in `start'
/Applications/Komodo IDE 11.app/Contents/SharedSupport/dbgp/rubylib/rdbgp2.rb:1836:in `<main>'

Can anyone suggest what else I need to do?

Many thanks,
Peter


#2

Hey @pemcg,

I’ve filed a big for this:

Could you add any missing details? I’d be interested to know if this was working for you before and then after a change, it stopped working. eg. Byebug version change, Ruby version change, a different version of Komodo working, etc.

  • Carey

#3

Thanks. Unfortunately this is the first time I’ve tried debugging Ruby so no changes that I can report.


#4

Hi Carey -
It was definitely not a Ruby or a Byebug version change. Neither of those have changed on my Mac in about 9 months. It seems to have stopped working after the last patch for Komodo 11.1. I do not debug Ruby very often but it has been broken for at least a few months now.

Thanks,

Brad


#5

Komodo 11.1 came out a week ago or so. It didn’t break in 11.1 Are you saying it’s been broken since 11 was release? Has this been reported?

  • Carey

#6

Hi Carey -

If this is the first you have heard of it, I would say it has not been reported. Not trying to be glib or sarcastic. /shrug/
I dug up a bunch of past history that will hopefully be helpful to you. Or not, because contrary to my earlier response, both Ruby and Byebug have upgraded on my machine since the last time I checked.

So this is what worked for me a few months ago (the last time I did a project in Ruby):
Komodo 11.0.x
Ruby 2.4.x
Byebug 9.0.6.

Now, since then I have had an RVM issue, ripped out all my Rubies (except the Mac default) and started over again. My current setup is this:
Komodo 11.1.0
Default Ruby is 2.5.1p57
Default Gem List shows byebug (10.0.2, 9.0.6)

When I try to run anything in Ruby - even the good old ‘puts “hello world”’ I get the response Peter did above.

If there is anything you want me to try or modify let me know and I’m happy to help out.

  • Brad

#7

@bellbrad13,

Thanks for rechecking things. For now I think I’m good. I updated the ticket I filed with your added info. Hopefully ByeBug didn’t change it’s interface too drastically and it’s just passing some extra optional arg to Komodo that I can ignore or use.

  • Carey

#8

@pemcg or @bellbrad13, I have a test build that I’m able to send either of you if you email careyh@activestate.com. I only had time to try a quick patch but don’t have time right now to test on OSX then pass to QA for a quick once over. If you want to give it a try email above and i’ll send you a link to download.

  • Carey

#9

Looks like my fix didn’t work and Byebug changed significantly enough to break integration with Komodo. The only thing I can recommend for now is roll Byebug back to a version that worked. I have a few minutes this morning that i’m going to use to figure out which version works.


Time passes

So Byebug 9.1 works.

$ gem uninstall byebug
$ gem install byebug -v 9.1.0

That should get the Ruby debugger working for you.

  • C

#10

that works, thanks


#11

Same problem with Komodo 12 under Mac, Ruby 2.7.1xxx

byebug 9 is significantly outdated now, any chance this could be updated to work with recent versions ?