Ruby debugger: byebug error message when debugging


#1

Hi,

I’m trying out KomodoIDE 11 on Ubuntu with Ruby 2.4 managed by RVM. When I debug, I get the following error message:
Screenshot%20from%202019-09-24%2021-51-09

After installing byebug 11 as instructed, I still get the same error message. I tried an older version of byebug (9.1) as well to no avail.

Thank you for your thoughts!


#2

Hi @Tim_Peti,

My guess is that you’re not pointing Komodo at the Ruby version that you installed byebug in. How have you configured the Ruby interpreter to use in Komodo?

  • Carey

#3

Hi Carey,

Thank you for your prompt reply. My ruby was not automatically found upon Komodo install and I specified its path through settings:


Byebug is installed here:

Tim


#4

@Tim_Peti,

Confirm that Ruby can load byebug. So run ~/.rvm/rubies/ruby-2.4.0/bin/ruby -e "require 'byebug';print('found it')" in your terminal.

I just did a simple setup with Ruby 2.4, installed byebug and ran the debugger and it works so my guess that the issue lies in your RVM setup.

  • Carey

#5

Hmm, this seems to work:


#6

I wonder if I should let Komodo search for installed languages again as it did in the beginning. How do I re-start that?


#7

Ok, I have it figured out. Since RVM is in charge of all the installed Ruby versions, Komodo needs to be pointed to a different file (rvm-auto-ruby). Mine can be found here:
Screenshot%20from%202019-09-25%2021-41-48

Thank you for your input!


#8

Oh nice find! I not familiar with RVM so thanks for digging @Tim_Peti. My next guess was going to be an envvar that’s only set in your terminal…

  • Carey