Remote debug displays message "Error: That port is already in use."

Remote debugging used to work fine. Now when I try it, I get the message “Error: That port is already in use.”. I am debugging a Linux AWS machine from Win 7 running Komodo IDE 8. Komodo 7 does the same thing. I have tried both ports 9000 and 9001.

I have loaded the Komodo 8 remote debugging files onto the remote Linux machine. The command I am using on the remote machine is:
~/bin/pydbgp -d my_ip_address:9000 path/to/ runserver --noreload

Can you check what is using those ports?

sudo netstat -tulpn says that nothing is using 9000 or 9001:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0*               LISTEN      1378/memcached  
tcp        0      0*               LISTEN      22542/apache2   
tcp        0      0    *               LISTEN      22531/nginx: master
tcp        0      0    *               LISTEN      1432/sshd       
tcp        0      0  *               LISTEN      22619/postgres  
tcp        0      0  *               LISTEN      1372/exim4      
tcp        0      0   *               LISTEN      22531/nginx: master
tcp6       0      0 :::22                   :::*                    LISTEN      1432/sshd       
tcp6       0      0 :::5432                 :::*                    LISTEN      22619/postgres  
udp        0      0    *                           1411/dhclient3

Sorry my bad, you are using WIndows 7 as your dev machine and linux as the server. You need to do the port check on Windows. Try this -

For port 9000, Resource Monitor shows only komodo:

Image	PID	Address	Port	Protocol	Firewall Status
komodo.exe	10104	IPv4 unspecified	9000	TCP	Allowed, not restricted

And that’s while Komodo is not running? (ie. before starting Komodo, which would give you the “port in use” error)

No. If I close Komodo, then nothing is using the port.

But Komodo still gives you the error when you start it?

With Komodo not running, nothing is using port 9000. After I start Komodo, it is using the port. Then when I run the debugger on the remote box, I get the error.

Wait so are you seeing this error on the server or the client? (Linux or Win)

Uh oh. You’re right. I wasn’t stopping apache before running the debugger. Sorry for the goose chase.