Refresh rate / framerate issues on G-sync monitor

I’ve been looking around but couldn’t find anyone with a similar issue or fix this myself.

So I’ve been using Komodo Edit for years now at home and at work, and since recently I have a Gsync monitor (Philips 272G5DYEB) and I notice whenever I use Komodo on the Gsync monitor (with Gsync active) the screen refresh rate / framerate drops which is very nauseating to work with, it seems to have effect on my second screen Dell monitor as well when playing a video on there for example it seems to drop frames and hitch up a lot. When I open another application (and still have Komodo in the background) it all runs fine again. As soon as I bring forth the Komodo window it freaks out again. It only seems to happen on my Gsync monitor, when I put Komodo on the other screen it seems to work fine in all situations

I’ve updated all my drivers, currently work on Windows 10 and tried different cables and such but nothing seems to work, it looks like it’s purely a software-side issue to me.

Try disabling hardware acceleration:

  1. Open a file
  2. Preview the file “in a browser” but set it to open in a Komodo tab
  3. Replace the file address with about:config to get into the settings
  4. Look for layers.acceleration.disabled and set it to true
  5. Restart Komodo

Thanks for the quick reply. It seems to have done the trick!

The solution worked for me too, or seems to have so far.

I have a different monitor, mine is an acer and prior to implementing the change using Komodo IDE went as far as to cause some sort of driver crash.