Pylint checking inside virtualenv on Windows

Hi there,
I fiddle around to get Pylint working inside a virtualenv on my Win7 DEV machine, using Komodo IDE 9

In my virtualenv pylint is properly installed and working.

After that I tried to set Syntax Checking with pylint within my project preferences.
(Where my project of course is set to use the Python interpreter within the virtualenv.)

But it’s obviously not able to find the installed pylint…as it says “current python instance c:\python27… doesnt have pylint installed”.
Which is correct, but it refers to my system Python.

So the question is: How can I tell Komodo to use the virtualenvs python interpreter (and it’s pylint)?

Is this a bug or do I miss something?

BR
Michael

Hi @normic,

Everything so far is working as it should. What you’re missing is setting the project language python preference to the virtualenv Python interpreter, otherwise it uses the global interpreter that knows nothing about your virtualenv.

Right click project > Project Properties > Languages > Python > Interpreter

You should be set after that.

Thanks for the fast respone @careyh,
but I already have this setting…

It’s actually set to use: c:\dev\venvs\ims\scripts\python.exe
Whereas my system python is under c:\python27…

I now figured out what went wrong :smile:

As mentioned before I have had the python interpreter set to my virtualenv, additionally I have had the virtualenvs site-packages and my project root set under Additional Python Import Directories.

Now I’ve additionally set the PYTHONPATH under Project Properties > Environment to the same entries as Additional Python Import Directories and everything works as expected.

I guess this is mainly a problem occuring under Windows.

Maybe it’s of help to someone else…