Publishing says "Remote file was removed..." but it was not

Hello - I have just started trying to use Publishing / Synch, but I am very wary of using it as it doesn’t seem to be working correctly.

I have been using the “When a file is saved locally, auto-push to server” for a couple of months now quite happily, and on this project specifically for a few days.

The auto-push on this project worked for a while, but then stopped. When I tried to manually Push the file I got error “Conflict the remote file has changes”, even if I delete the remote file. So I thought I’d try synchronizing the site.

  1. I set up my publishing options with directories to exclude and did a synchronize. Everything was OK.
  2. I realised I wanted to remove 2 directories “languages” & “templates” from the exclusions, so I did and ran another Status Check. This was less than 2 mins after the first run. No one else is using the site.
  3. All other files and directories apart from those just added now say “Remote file was removed…” but they have not been

I had this happen on a site a few weeks ago and it completely messed things up, so left it a while until I had a bit of time to try / check again.

Build Info
Komodo IDE, version 9.2.1, build 87651, platform win32-x86.
Built on Tue Sep 01 17:19:15 2015.

Thanks very much

Hi, if possible, would you please update to our latest 9.3.2 release and see if that has fixed your problem? Thanks!

Thanks for such a quick response, sorry its taken me a while to get back to you.
This is OK now, thanks :smile:
Just for info the sync seems to be a bit temperamental with large numbers of files, but if I run it 4 or 5 times it eventually gets there.

Hi sorry it’s not behaving at all.

I had the same message again but with about 8 “Local file was removed…” messages, they were not.
So I thought I’d just download it manually anyway using FileZilla and rerun the sync.
I still get the same message on these files, and I have some new ones as well that didn’t show before.
I also resolved a conflict on one file by downloading the remote file, but on the re-run it was still there.

I have not touched any files on the site - its one I am not currently working on, as I’d like to get this sync working.
I started with an empty local folder and so everything was downloaded off the server.

Also I when I have a file in conflict and I right-click >> diff the popup screen is empty.

Could you share your error log when next time this problem occurs? Help > Troubleshooting > View Log File.

Thanks - I think it may have something to do with trying to use Prepros too as I am having intermittent trouble with that as well, so I’m going to change my setup and see how I go.