Publishing from Places/Publish on save broken with 9.2.0 IDE update


Just updated Komodo IDE to 9.2.0, and even though publishing from Tools/Publishing seems to work just fine, Publish on save doesn’t work and trying to publish from Places (Right click on file/Publishing/Push) throws the following exception:

Any thoughts on this?


Getting this in pystderr.log

    ERROR:xpcom:Unhandled exception calling 'int8 * pushLocalUri(in unicode &, optional in nsISomething, optional in boolean, out retval nsISomething);'
Traceback (most recent call last):
  File "/Applications/Komodo IDE", line 300, in _CallMethod_
    return 0, func(*params)
  File "/Applications/Komodo IDE", line 757, in pushLocalUri
    "Uri %r does not belong to any publishing configurations" % (uri))
Exception: 2147942487 (Uri u'file:///Users/splante/Google%20Drive/_sandbox/Fradette/fradette/js/min/app-min.js' does not belong to any publishing configurations)
[2015-08-05 09:25:56,508] [ERROR] commands: An error occurred executing the cmd_publishingPlacesPushFile command
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [koIPublishingService.pushLocalUri]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://publishing/content/publishing.js :: publishing_push :: line 202"  data: no]
+ QueryInterface (function) 3 lines
+ message (string) 'Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [koIPublishingService.pushLocalUri]'
+ result (number) 2147500037
+ name (string) 'NS_ERROR_FAILURE'
+ filename (string) 'chrome://publishing/content/publishing.js'
+ lineNumber (number) 202
+ columnNumber (number) 0
+ location (object) JS frame :: chrome://publishing/content/publishing.js :: publishing_push :: line 202
| + QueryInterface (function) 3 lines
| + language (number) 2
| + languageName (string) 'JavaScript'
| + filename (string) 'chrome://publishing/content/publishing.js'
| + name (string) 'publishing_push'
| + lineNumber (number) 202
| + columnNumber (number) 8
| + sourceLine (string) ''
| + caller (object) JS frame :: chrome://publishing/content/publishing.js :: PublishingController.prototype.do_cmd_publishingPlacesPushFile :: line 277
| + formattedStack (string) 'publishing_push@chrome://publishing/content/publishing.js:202:8
PublishingController.prototype.do_cm'...395 chars
| + inner (object) null
| + data (object) null

Hey @simonpca, I’m eager to dig into this, but please report it on the bug tracker:

When you do, please include full version information including what version you upgraded from. Also include whether you tried the exact same actions (down to using the exact same file) on the previous version.

Thank you!

Just solved it, seems that it came from a folder with a space in its name… Don’t know why it suddenly stopped working (as this folder wasn’t ever renamed), but removing the space, deleting and recreating the publishing configuration seemed to do it.

Kinda lame, but works.

Hi @simonpca, this is an issue that was actually reported in Komodo 9.1 and was fixed for 9.2. My fix may have been bad but there are too many unknowns at the moment. Could you provide the following:

  • Your OS and version
  • confirm the space wasn’t there before

Please also try re-installing Komodo 9.2.

  • Carey

I have the same issue running Windows 8.1 and Komodo IDE, version 9.2.0, build 87616, platform win32-x86. Built on Tue Aug 04 10:31:35 2015.
My folder when using 9.1 had a space in it and in the main gave no problems, but would fail to push to server maybe once in 10 times or more. This same folder now refused to push at all, yet other folders without spaces were pushing OK, I have removed the space and replaced it with _ and recreated the profile and now all seems to be fine.