Problems with mouses actions since last update


#1

Since laste update, it’s hard to work with Komodo Edit because of mouses actions

Editing php code :

  • after selecting code, it’s impossible to move it using drag-drop: it doesn’t move
  • after selecting code, when I right-clic to copy, code is unselected, and cursor moves a few lines upper
  • idem pasting: when I right-clic, cursor moves 3 or 4 lines upper

in fact, when I right-click, cursor moves upper causing de-selection

Komodo Edit, version 8.5.4, build 14424, platform linux-x86_64.
Built on Thu Aug 14 07:05:55 2014.

Distrib : Linux Mint 16 Petra KDE (Ubuntu 13.10)


#2

Do you have the minimap enabled? If so, could you try disabling it and seeing if your issue persists? (View > View Minimap).


#3

Minimap disabled : same thing.


#4

Profile (~/.komodoedit/8.5/) deleted, same thing.


#5

I’m wondering if this is related to monitor DPI settings (display scaling).

I’d be curious if resetting display scaling to 1, or changing to a DPI of 96 fixes the problem?

Cheers,
Todd


#6

YEESSSS ! ! !

Thanks a lot.

I’ve put a new file in /etc/X11/Xsession.d/
containing : xrandr --dpi 96x96
restart X, and it’s good !

(instructions about dpi config found here : http://askubuntu.com/questions/197828/how-to-find-and-change-the-screen-dpi )

Optimum dpi should be 100x100 for my screen, but for Komodo, 96x96 is needed to work fine again.

thanks, have a nice day.


#7

As I’ve not been able to reproduce this issue myself, I’m wondering if it’s possible to keep your optimal DPI setting (of 100) and tweak one of Komodo’s file’s to suit.

The file is scimoz_wrapper.js inside of your Komodo installation, full location is:
Komodo-IDE-9/lib/mozilla/components/scimoz_wrapper.js

And then find the number 96 (see below) and change it to your wanted DPI value:

const kDefaultDPI = Services.appinfo.OS == "Darwin" ? 72 : 96;

Does that then work properly?


#8

I’ve just tried :
config X11 to 100x100 dpi
change Komodo-Edit-8/lib/mozilla/components/scimoz_wrapper.js to
const kDefaultDPI = Services.appinfo.OS == “Darwin” ? 72 : 100;

But this is not good: right-clic on selected text un-select it.

I’m back to 96dpi


#9

Okay, thanks for trying it out. I’ll have to do some deeper digging into this one.


#10

I ran into this issue (right mouse click de-selection) in Mint 17.3 (distro based on Ubuntu), it’s extremely frustrating so I wanted to post my experience. To resolve, go to System Settings, Fonts, Font Settings pane, reduce the Text scaling factor to 1.0. Best of luck with this fantastic IDE.


#11

Fwiw this will be fixed in Komodo 10


#12

I am using Komodo Edit 11.1.2 and I am still experiencing this exact same issue. The platform is Ubuntu and display scaling is 200%. When I run xdpyinfo | grep dots it returns “resolution: 96x96 dots per inch”. Any ideas what is causing this? This is the only application I have experienced this behavior in.